[GE users] SGE on SGI IA 64 Linux 2.4, glibc 2.2

andy andy.schwierskott at sun.com
Tue Feb 17 17:11:20 GMT 2009


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hi,

the reason why we require to use glibc 2.3.2 is because the compile host
for our courtesy binaries is RHEL 3 with that glibc version.

There should be no principal reason that SGE does not run on glibc 2.2
systems when it was sucessfully compiled on such a host. The Â?only thing
which potentially could cause troubles are issues with the threading
library.

You can try the following:

  - install SGE on a working host with classic spooling
  - then shutdown qmaster/scheduler and delete the "act_qmaster" file
  - set all env variables and start qmaster on IA64 manually
  - if this works and you can do a qstat etc. you can start the scheduler
  - if it does not work you can more easily find out where qmaster
    exits/crashes/hangs

Andy

> Hello,
>
> I have successfully compiled SGE 6.1u6 on the SGI IA64 machine running Linux 2.4 (glibc 2.2). See details on the system below.
>
> However, I am having multiple problems while installing and running the qmaster.
>
> For example, the installation script fails at AddConfiguration with a "permission problem" error message, that can be "cured" by removing ExecuteAsAdmin from AddConfiguration(). If it's fixed then the script will hang at AddLocalConfiguration. The installation script will hang pretty much at every stage trying to run spooldefaults with different parameters. Eventually, playing with different parts of the script, it's possible to get default/common populated with all the necessary files and try to start the qmaster.
>
> But the qmaster does not start and there is no error message. Then, when sge_schedd starts, it cannot connect to the qmaster and fails leaving several scheduler processes running in background.
>
> Can anybody provide any comments/advice on running/installing SGE on Linux (kernel 2.4 and glib 2.2) on IA64?
>
> Is it possible to run SGE on IA64 with glib 2.2 at all?
>
> Thank you
> Serge
>
>
> $ uname -a
> Linux 2.4.21-sgi240rp04021313_10046 #1 SMP Fri Feb 13 14:02:27 PST 2004 ia64 unknown
>
> $ ls -al /lib/libc*
> Feb 11  2004 /lib/libc-2.2.4.so
> ...
>
> $ rpm -qa | grep glibc
> glibc-2.2.4-32.8sgi240r04021115_10044
> ...
>
> $ cat /etc/redhat-release
> Red Hat Linux Advanced Server release 2.1AS (Derry)
>
> $ cat /etc/sgi-release
> SGI ProPack 2.4 for Linux, Build 240rp04021313_10046-0402131355
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=108246
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=108260

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list