[GE users] Error: libc.so.6: failed to map segment from shared object:

prentice prentice at ias.edu
Tue Feb 24 18:11:59 GMT 2009


My cluster nodes have 16GB of RAM, which SGE detects as 15.7G. I want to
set h_vmem as consumable, so I set h_vmem on all my nodes to a value
safely below that limit, say 15G (I've also tried 15.5G and 15.7G, with
the same effect):

for i in $(seq -w 64); do qconf -mattr exechost complex_values
h_vmem=15G node${i}; done

I then set h_vmem to be consumable:

h_vmem              h_vmem     MEMORY      <=    YES         YES
0        0

Now when I run an MPI test job (a simple "hello, world" type program,
that I've been using as a test case for months now), I get this error:

mpirun: error while loading shared libraries: libc.so.6: failed to map
segment from shared object: Cannot allocate memory

If I request a certain value for h_vmem, (using -l h_vmem=7G, for
example), I don't get this error, but then the job runs for a really
long time. It eventually does finish, but no output is written to the
files.

If I change the h_vmem complex so that it is not consumable, everything
works fine.

If I define a default value for h_vmem like so:

qconf -sc | grep h_vmem
h_vmem              h_vmem     MEMORY      <=    YES         YES
1.9G     0

I get the same behavior as if I specify h_vmem using the -l switch.

Any ideas what's causing the libc.so.6 error, or the strange behavior
when h_vmem is set to consumable? I'm using SGE 6.2:

$ qstat -help  | head -1
GE 6.2

-- 
Prentice

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=113623

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list