[GE users] Error: libc.so.6: failed to map segment from shared object:

prentice prentice at ias.edu
Tue Feb 24 18:47:11 GMT 2009


reuti wrote:
> Am 24.02.2009 um 19:11 schrieb prentice:
> 
>> My cluster nodes have 16GB of RAM, which SGE detects as 15.7G. I  
>> want to
>> set h_vmem as consumable, so I set h_vmem on all my nodes to a value
>> safely below that limit, say 15G (I've also tried 15.5G and 15.7G,  
>> with
>> the same effect):
>>
>> for i in $(seq -w 64); do qconf -mattr exechost complex_values
>> h_vmem=15G node${i}; done
>>
>> I then set h_vmem to be consumable:
>>
>> h_vmem              h_vmem     MEMORY      <=    YES         YES
>> 0        0
>>
>> Now when I run an MPI test job (a simple "hello, world" type program,
>> that I've been using as a test case for months now), I get this error:
>>
>> mpirun: error while loading shared libraries: libc.so.6: failed to map
>> segment from shared object: Cannot allocate memory
> 
> If h_vmem is set, it's also often necessary to request -l h_stack=32M  
> or 128M.
> 

Reuti,

Thanks. That fixed it. You did mention that in a previous e-mail and I
forgot, so I apologize for making you tell me the same thing twice.
Would it be a problem to make h_stack consumable and set the default
value to 32M in the complex configuration so users don't need to worry
about it?
-- 
Prentice

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=113647

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list