[GE users] cannot run in PE "smp" because it only offers -2147483648 slots

kdoman kdoman07 at gmail.com
Tue Feb 24 20:10:36 GMT 2009


hello list -
I need to submit only one job to one machine even though the machine
has four cores. So I ran the command "qconf -ap smp", edit the
slots=1000, saved and added smp to the queue (via qconf -mq):

qconf -sp smp:
==============
pe_name           smp
slots             1000
user_lists        NONE
xuser_lists       NONE
start_proc_args   /bin/true
stop_proc_args    /bin/true
allocation_rule   $pe_slots
control_slaves    FALSE
job_is_first_task TRUE
urgency_slots     min

qconf -sq all.q
==============
qname                 all.q
hostlist              @allhosts
seq_no                0
load_thresholds       np_load_avg=1.75
suspend_thresholds    NONE
nsuspend              1
suspend_interval      00:05:00
priority              0
min_cpu_interval      00:05:00
processors            UNDEFINED
qtype                 BATCH INTERACTIVE
ckpt_list             NONE
pe_list               make mpich mpi orte smp
rerun                 FALSE
slots                 2
.
.
etc...

After I submitted the jobs, all jobs stayed in the 'qw' states. qstat
-j <job-id> gave me this:
cannot run in PE "smp" because it only offers -2147483648 slots

Thanks all.

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=113694

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list