[GE dev] s390x Architecture

ron ron_chen_123 at yahoo.com
Wed Jul 15 06:05:15 BST 2009


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Seems like the -no-rmon flag is broken, and I don't recall using that flag before.

And besides -no-rmon, I have not tried -no-intl before. But all other aimk flags look normal and common.

And remember to do an "aimk <add your aimk flags> clean" to clean the objects compiled with other aimk or compiler options. Otherwise, some binaries might not link, or you might get unexpected behaviours.

 -Ron



--- On Wed, 7/15/09, rayson <rayrayson at gmail.com> wrote:
> Please compile SGE without the -no-rmon aimk flag.
> 
> I could reproduce the problem when I have that flag turned
> on on my
> Linux PPC machine.
> 
> Rayson
> 
> 
> On 7/14/09, uriel01 <uriel.carrasquilla at mail.mcgill.ca>
> wrote:
> > gcc -DSGE_ARCH_STRING=\"lx26-s390x\" -O3 -Wall
> -Wstrict-prototypes -DUSE_POLL -DLINUX -DLINUXS390X
> -DLINUXS390X_26 -D_GNU_SOURCE -DGETHOSTBYNAME_R6
> -DGETHOSTBYADDR_R8  -DHAS_IN_PORT_T -m64
> -DNO_SGE_COMPILE_DEBUG
> -I/off_home/gridengine/db-4.4.20/lx26-s390x/include/
> -DTARGET_64BIT  -DSPOOLING_classic  -DNO_JNI
> -DCOMPILE_DC -D__SGE_NO_USERMAPPING__ -I../common -I../libs
> -I../libs/uti -I../libs/juti -I../libs/gdi -I../libs/japi
> -I../libs/sgeobj -I../libs/cull -I../libs/rmon
> -I../libs/comm -I../libs/comm/lists -I../libs/sched
> -I../libs/evc -I../libs/evm -I../libs/mir -I../libs/lck
> -I../daemons/common -I../daemons/qmaster -I../daemons/execd
> -I../daemons/schedd -I../clients/common -I. -fPIC -c
> ../libs/sched/sge_select_queue.c
> > ../libs/sched/sge_select_queue.c: In function â:
> > ../libs/sched/sge_select_queue.c:4174: warning:
> implicit declaration of function â
> > ../libs/sched/sge_select_queue.c:4174: error: â
> undeclared (first use in this function)
> > ../libs/sched/sge_select_queue.c:4174: error: (Each
> undeclared identifier is reported only once
> > ../libs/sched/sge_select_queue.c:4174: error: for each
> function it appears in.)
> > ../libs/sched/sge_select_queue.c:4174: error: â
> undeclared (first use in this function)
> > make: *** [sge_select_queue.o] Error 1
> > not done
> >
> >
> ------------------------------------------------------
> > http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=39&dsMessageId=207177
> >
> > To unsubscribe from this discussion, e-mail: [dev-unsubscribe at gridengine.sunsource.net].
> >
> 
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=39&dsMessageId=207191
> 
> To unsubscribe from this discussion, e-mail: [dev-unsubscribe at gridengine.sunsource.net].
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=39&dsMessageId=207253

To unsubscribe from this discussion, e-mail: [dev-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list