[GE users] can't start pthread with Gridengine

s_kreidl sabine.kreidl at uibk.ac.at
Fri Jul 24 08:27:18 BST 2009


Hi Chris,

its just a wild guess, but we ran into trouble with Matlab and other 
applications with older versions of SGE when submitting jobs with a h_rt 
limit (which in the older versions also set the stack size to the size 
specified for h_rt -> see "ulimit -a"). I heard somewhere that this 
setting was also causing pthreaded application to crash, though I never 
verified that myself.

As I said, just a wild guess. But would you let me know, if this was 
indeed the problem?
Best,
Sabine

echoecho schrieb:
> Yes something is different about the environment when jobs are started by SGE.  I saved the output from env generated by a bash script submitted through qsub, then ssh'ed into a node directly, loaded the saved environemnt variables and tried my python pthreads test script.  It successfully created a thread so I don't think any difference in environment variables is the cause.
>
> Are there any special configurations that need to be made to get Gridengine to play nice with libpthreads?
>
> Chris
>
>   
>> SGE doesn't do anything to your scripts other than execute them.  
>> Perhaps there's something different about the shell or environment that 
>> is being started on the exec node.  Try running "qrsh env" to see how 
>> the environment variables are set when you're job is executing on the 
>> remote machine.
>>
>> Daniel
>>
>> echoecho wrote:
>>     
>>> Hello,
>>>
>>> I'd like to run multi-threaded applications on our cluster as Gridengine jobs, but it appears that Gridengine is not allowing the creation of pthreads.  I've tested two applications: BWA (short-read DNA sequence alignment) and a simple python script that makes one thread.  In both cases the programs cannot create pthreads.  I've tried with and without a parallel environment set up with this configuration:
>>>
>>> $ qconf -sp smp
>>> pe_name           smp
>>> slots             999
>>> user_lists        NONE
>>> xuser_lists       NONE
>>> start_proc_args   /bin/true
>>> stop_proc_args    /bin/true
>>> allocation_rule   $pe_slots
>>> control_slaves    FALSE
>>> job_is_first_task TRUE
>>> urgency_slots     min
>>>
>>> Both applications can create threads if started directly on a compute node outside of SGE.
>>>
>>> Attached is the python script I've used to test thread creation and the bash script that creates the submit script and calls qsub.
>>>
>>> Any help in troubleshooting this problem would be much appreciated.
>>>
>>> Thanks,
>>> Chris
>>>
>>> --
>>> Chris Berthiaume
>>> University of Washington
>>> Center for Environmental Genomics
>>>
>>> ------------------------------------------------------
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=209228
>>>
>>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>>>
>>>       
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=209269
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=209302

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list