[GE issues] [Issue 3058] New - qsub man page does not mention the existance of $JOB_SCRIPT environment variable within a job

dagru d.gruber at sun.com
Wed Jun 17 15:11:26 BST 2009


http://gridengine.sunsource.net/issues/show_bug.cgi?id=3058
                 Issue #|3058
                 Summary|qsub man page does not mention the existance of $JOB_S
                        |CRIPT environment variable within a job
               Component|gridengine
                 Version|6.2u2
                Platform|All
                     URL|
              OS/Version|All
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|man
             Assigned to|andreas
             Reported by|dagru






------- Additional comments from dagru at sunsource.net Wed Jun 17 07:11:22 -0700 2009 -------
Submit following job script: 

#!/bin/sh
echo JOB_SCRIPT $JOB_SCRIPT
echo SGE_JOB_SPOOL_DIR $SGE_JOB_SPOOL_DIR


The result is:

JOB_SCRIPT /.../.../sge61u6/default/spool/XXXhostnameXXX/job_scripts/27
SGE_JOB_SPOOL_DIR /.../.../sge61u6/default/spool/XXXhostnameXXX/active_jobs/27.1

But qsub man page does not mention the existence of JOB_SCRIPT. 
Be aware that JOB_SCRIPT can not be changed via -v (this has no effect). 

This is true for at least 61u6 and 62u2.

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=36&dsMessageId=202111

To unsubscribe from this discussion, e-mail: [issues-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list