[GE users] Possible ARCo bugs

jana jana.olivova at sun.com
Fri Jun 19 12:14:15 BST 2009


Hi,

You could also try to download the latest SWC patch, I think it is 3.1, patch id 125951-18

Jana



soeren_g wrote:

Various bugs in ARCo found

Hello,

we just installed ARCo on a test system and were surprised to find a lot of bugs in such a usefull piece of software ,-)

SGE: 6.2u2_1
JVM: Sun JDK  1.5.0_04
OS: SLES 10
Sun Web Console: 3.0.2
Mysql. 5.0.26

1) Date stamps: All dates in table show up like "Date.asString()", e.g. they look like "[B at b67f7c". This seems to be a general programming flaw - so obvious that I doubt it's really a bug ,-)


2) The reports "Number of Jobs completed" results in an Java exception (as seen in the console debug log) while drawing the chart (pls. see attached screenshot, documents the above bug as well).

18/06/2009 14:37:18|S4BY112|.arcomodule.ChartServlet.doGet|E|error java.lang.ClassCastException
                              java.lang.ClassCastException: null


3) Most strang bug so far...The "Job log" requests works nice when used with Firefox but fails when called from IE 7. For IE I noticed that the server https certificate is marked as invalid although I imported it. The debug log yields:

18/06/2009 14:38:20|S4BY112|rcoServlet.onUncaughtException|E|Encountered an internal exception: javax.servlet.ServletException: The request was not handled by the specified handler "com.sun.grid.arco.web.arcomodule.LateBindingViewBean at f40b08"
                              javax.servlet.ServletException: The request was not handled by the specified handler "com.sun.grid.arco.web.arcomodule.LateBindingViewBean at f40b08"
                                com.iplanet.jato.ApplicationServletBase.dispatchRequest(ApplicationServletBase.java:984)
                                com.iplanet.jato.ApplicationServletBase.processRequest(ApplicationServletBase.java:615)
                                com.sun.grid.arco.web.ArcoServletBase.processRequest(ArcoServletBase.java:538)
                                com.iplanet.jato.ApplicationServletBase.doPost(ApplicationServletBase.java:473)
                                javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
                                javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
                                sun.reflect.GeneratedMethodAccessor77.invoke(Unknown Source)
                                sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                                java.lang.reflect.Method.invoke(Method.java:585)
                                org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:243)


So guys...you can do better than that ,-)) Anyways if these are real bugs I am happy to file some issues.


Thanks & regards,
Soeren Gerlach

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=202220

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net<mailto:users-unsubscribe at gridengine.sunsource.net>].


________________________________

[cid:part1.09020002.06000905 at sun.com]



    [ Part 2, "ATT00001.png"  Image/X-PNG (Name: "ATT00001.png") 23 KB. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list