[GE users] can't get password entry for user either the user does not exist or NIS error

whitingeric eric.whiting at inl.gov
Wed Jun 24 15:10:13 BST 2009


I saw a similar qstat error yesterday -- not the same one as described,
but troubling just the same.

In my screen history I see a qstat that worked, followed by the very
next command that gave the failure 'not found in password database'.
Within a few seconds the error cleared.

I assume this might be a NIS or network hiccup, but wondered if there
could be an issue with SGE. We did not see this sort of error until
after we upgraded from 6.0u8.

6.2u2_1


> qstat
job-ID  prior   name       user         state submit/start at    
queue                          slots ja-
task-ID
----------------------------------------------------------------------------------------------------------
-------
 114740 0.50500 QLOGIN     johnjs       r     06/16/2009 17:00:42
all.q at xxxx115                    1
 <SNIP>
 115377 0.52060 ncj        bgs          r     06/23/2009 13:33:47
all.q at xxxx027                   40

> qstat
error: user "bgs" not found in password database


pollinger wrote:
> This error message just tells you that the getpwnam_r(3C) failed. You 
> don't need NIS to solve this, you just have to set up your user DB in a 
> way that getpwnam_r(3C) can retrieve the informations of the user from it.
>
> What your user DB is should be defined in /etc/nsswitch.conf.
>
> Regards,
> Harald
>
> On 06/24/09 14:49, muxecoid wrote:
>   
>> The error message is "can't get password entry for user either the
>> user does not exist or NIS error". I want to get rid of this with
>> least effort possible. I do not have NIS installed so I just copied
>> the user names, UIDs and passwords over all machines (only 3 of them)
>> manually.
>>
>> I tried to install NIS but I do not know what it is and it appears to
>> be very hard to configure.
>>
>> Any easy workarounds?
>>     
>
>
>
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=203305

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list