[GE users] qsh

pvdmeer pvdmeer at gmail.com
Thu Jun 25 14:00:58 BST 2009


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Dear SGE users,

I recently ran into a problem of users running their processes outside of SGE. I "fixed" it by changing scheduler rules. But this still allows, in very high load situations, jobs to be scheduled on fully loaded systems..

The obvious solution is to force them to use SGE. However, their software requires an X windows display to be active.. So, I wondered if "qsh" might offer us some help.

However:

taygeta [examples]% qsh
Your job 2670 ("INTERACTIVE") has been submitted
waiting for interactive job to be scheduled ...qstat -f


Your "qsh" request could not be scheduled, try again later.

I checked to see if there were slots left in the cluster and there were plenty.. A normal qsub task also worked.

Then qlogin maybe?

taygeta [examples]% qlogin
local configuration taygeta.sron.nl<http://taygeta.sron.nl> not defined - using global configuration
Your job 2671 ("QLOGIN") has been submitted
waiting for interactive job to be scheduled ...error: 1: qlogin_daemon "none" is not an absolute path

Am I missing something here? Do I need to configure the scheduler or provide some additional parameters?

Any hints will be appreciated.

With kind regards,

Pieter van der Meer



More information about the gridengine-users mailing list