[GE users] Jobs in wrong queues

udowaechter udo.waechter at uni-osnabrueck.de
Fri Mar 6 10:29:01 GMT 2009


Hello,
sorry I was gone for some days.
Now, for all the infos:

$ qconf -sul
GE-users
ikw
munin
nkg
www-data

$ for I in $(qconf -sul); do qconf -su $I; done
name    GE-users
type    ACL DEPT
fshare  0
oticket 0
entries @GE-users

name    ikw
type    ACL DEPT
fshare  0
oticket 0
entries @uguest, at ustaff, at ustudent

name    munin
type    ACL DEPT
fshare  0
oticket 0
entries munin

name    nkg
type    ACL DEPT
fshare  0
oticket 0
entries @nkg

name    www-data
type    ACL DEPT
fshare  0
oticket 0
entries root,www-data

The queues:

$ qconf -sql
default
electricsheep
ikw
munin
nkg
test

and xusers/users:
$ for I in $(qconf -sql); do qconf -sq $I |grep -e lists -e qname; done
qname                 default
user_lists            NONE
xuser_lists           ikw

qname                 electricsheep
user_lists            www-data
xuser_lists           ikw

qname                 ikw
user_lists            GE-users
xuser_lists           ikw

qname                 munin
user_lists            munin
xuser_lists           ikw

qname                 nkg
user_lists            nkg
xuser_lists           ikw

qname                 test
user_lists            NONE
xuser_lists           ikw

All these settings seem perfectly right:
Our user's primary group is one of ustaff,uguest,ustudent (in the ikw  
userlist). Thus, noone of this group should be able to run a job  
anywhere

The 2 interesting queues are nkg and ikw, where either members of  
group nkg or of group GE-users can run jobs.

All exec hosts are members of the default queue. The 2 queues ikw and  
nkg are disjunct sets of the default queue.

As I understood it, GE decides on its own where the job runs,  
depending on the user's primary group.
So, if I do "newgrp GE-users" and then run a job without requesting a  
queue, it should run in the ikw queue. If I do "newgrp nkg" it should  
run in the nkg queue.

Thanks,
udo.

On 04.03.2009, at 16:14, reuti wrote:

> Am 04.03.2009 um 15:46 schrieb udowaechter:
>
>> On 03/04/2009 11:54 AM, reuti wrote:
>>> Hi,
>>>
>>> Am 04.03.2009 um 10:51 schrieb udowaechter:
>>>> Oh, I forgot to say, that users do a "newgrp GE-users" before the
>>>> do a qsub.
>>>>
>>>> If they don't, their jobs hang with "has nor permission to run in
>>>> any
>>>> queue" or so which is what we want.
>>>
>>> can you check the used group? It's recorded in the accounting file,
>>> i.e. "qacct -j ..."
>>>
>>
>> Yes, I did check the group:
>> Currently I have an array-job running, that also runs in the wrong
>> queue.
>>
>> The group,department of this job is properly set to "GE-users"
>> Nevertheless, some tasks run on the proper queue, some run on the
>> queue
>> that no job should run on.
>
> What is the exact setting in the queue for user_lists, xuser_lists?
>
> -- Reuti
>
>
>> This is really strange.
>>
>> What can I do to debug this further?
>>
>> Thanks,
>> udo.
>>
>> ------------------------------------------------------
>> http://gridengine.sunsource.net/ds/viewMessage.do?
>> dsForumId=38&dsMessageId=120487
>>
>> To unsubscribe from this discussion, e-mail: [users-
>> unsubscribe at gridengine.sunsource.net].
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=120512
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net 
> ].
>

-- 
---[ Institute of Cognitive Science @ University of Osnabrueck
---[ Albrechtstrasse 28, D-49076 Osnabrueck, 969-3362
---[ Documentation: https://doc.ikw.uni-osnabrueck.de

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=122096

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list