[GE users] DRMAA GDI mismatch exception

zliu zliu at loni.ucla.edu
Tue Mar 10 19:08:51 GMT 2009


Hi,

We have an application that uses DRMAA.  Recently we upgraded SGE 6.2u1 from 6.1. After the upgrade, we saw this "GDI mismatch" exception hundreds of times a day.  We never had this exception before. 

Throwable = org.ggf.drmaa.DrmCommunicationException: GDI mismatch
        at com.sun.grid.drmaa.SessionImpl.nativeGetJobProgramStatus(Native Method)
        at com.sun.grid.drmaa.SessionImpl.getJobProgramStatus(SessionImpl.java:213)
        at execution.DRMAAQueueChecker.run(DRMAAQueueChecker.java:64)

The application uses DRMAA version 1.0 before and after the upgrade. We are using SGE 6.1u2 with the classic spooling method.  We are running the cluster with a customized Rocks Cluster v4.3 and CentOS release 4.5, kernel 2.6.9-55.0.2.ELsmp, x86_64.

Does anyone have any idea about this error? 

Thanks in advance.


================
Zhizhong Liu
Programmer Analyst, LONI Pipeline
Laboratory of Neuro Imaging, UCLA
635 Charles E. Young Drive South, Suite 225
Los Angeles, CA 90095-7332
zliu at loni.ucla.edu
================

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=126845

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list