[GE users] problems with modifying the job "simple.sh"

templedf dan.templeton at sun.com
Wed Mar 11 20:38:50 GMT 2009


Probably because your queue's shell_start_mode is set to 
posix_compliant, and your queue's shell is set to csh.

Daniel

tamara wrote:
> hi,
>  
> i modified simple.sh like the following:
>  
> #!/bin/sh
> #$ -S /bin/sh
> #$ -o /SGEoutput
> #$ -e /SGEoutput
> date
>  
> and so i get the output and the error in SGEoutput after i put 
> SGEoutput in NFS server:
> /SGEoutput
> *               rw,root_squash, sync,no_substree_check
>  
> and it works
> but when tired to make it forever loop printing the date in file.txt 
> like this:
>  
> #!/bin/sh
> #$ -S /bin/sh
> #$ -o /SGEoutput/output.txt
> #$ -e /SGEoutput/error.txt
> while [1]; do
> date
> done
>  
>  
> first i couldn't make it forever loop as it suppose to be in the last 
> three steps (i mean the job finished and it suppose not to finish)
> and there was no output in output.txt or error.txt
>  
> why is that?
>  
>  
> regards,
> tamara
>
> ------------------------------------------------------------------------
> See all the ways you can stay connected to friends and family 
> <http://www.microsoft.com/windows/windowslive/default.aspx>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=127862

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list