[GE users] Running qmaster and execd on Same Host?

abercromby basingwerk at talk21.com
Thu Mar 12 09:38:01 GMT 2009


I've run a grid engine on one system acting  as both qmaster and execd. I can't remember the exact version (it was 6.n), but it was in September last year, so it wasn't ancient.

I don't recall having any problems with startup scripts, 
but it might be worthwhile finding them after the qmaster
install, and moving them to temp files. Then do the execd install,
and merge the startup files by hand. That's one idea you could try, anyway.

Steve


--- On Thu, 12/3/09, ron <ron_chen_123 at yahoo.com> wrote:

> From: ron <ron_chen_123 at yahoo.com>
> Subject: Re: [GE users] Running qmaster and execd on Same Host?
> To: users at gridengine.sunsource.net
> Cc: "jlforrest" <jlforrest at berkeley.edu>
> Date: Thursday, 12 March, 2009, 4:09 AM
> I am 100% sure that one can run qmaster and execd on the
> same host.
> 
> The problem you encountered may be due to the older
> installation's rc startup scripts. You may want to
> delete them if they are not in use anymore.
> 
> <A bit off topic>
> IMO, our Mac startup scripts are a bit out-dated. We had
> some startup item scripts for earlier OSX versions. Then
> Apple switched to launchd, and we have not tested the
> launchd scripts from the BioTeam yet.
> 
> Would be great if people here can provide a definitive
> answer of "yes it works" or "no, xx does not
> work". If we can find a few YESes, then I will check
> the launchd scripts into cvs so that it will be included for
> the next release!
> </A bit off topic>
> 
>  -Ron
> 
> 
> --- On Sat, 3/7/09, jlforrest
> <jlforrest at berkeley.edu> wrote:
> > I'm working on installing SGE 6.2u1 on a bunch
> > of high end Mac Pros running OS X 10.5.6.
> > I'm using the "courtesy binaries" from
> > http://gridengine.sunsource.net/downloads/latest.html
> .
> > 
> > I've got qmaster running on the machine that's
> > also the Open Directory server. This is a dual
> > quad-core machine with 6GB of RAM so it still
> > has lots of umph left over so I tried
> > to install execd on it. Unfortunately the
> > install fails with the following error
> > message:
> > 
> > Specified cluster name
> > >$SGE_CLUSTER_NAME=jones-cluster< resulted in
> the
> > following conflict!
> > Detected a presence of old RC scripts.
> > /Library/StartupItems/SGE.jones-cluster/SGE
> > 
> > 
> > Stop the installation (WARNING: selecting 'n'
> will
> > remove the detected cluster) (y/n) [y] >>
> > 
> > Is there a way to run qmaster and execd on the same
> host?
> > 
> > Cordially,
> > -- 
> > Jon Forrest
> > Research Computing Support
> > College of Chemistry
> > 173 Tan Hall
> > University of California Berkeley
> > Berkeley, CA
> > 94720-1460
> > 510-643-1032
> > jlforrest at berkeley.edu
> > 
> > ------------------------------------------------------
> >
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=122416
> > 
> > To unsubscribe from this discussion, e-mail:
> > [users-unsubscribe at gridengine.sunsource.net].
> 
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=128121
> 
> To unsubscribe from this discussion, e-mail:
> [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=128339

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list