[GE users] launchd scripts on MacOSx Leopard servers

billmet billk at metrumrg.com
Thu Mar 12 12:32:35 GMT 2009


We have been using the launchd startup scripts from Bioteam for 6
months or so on a small cluster of Mac OSx Leopard servers. 
We have a relatively small cluster, compared to what I
have read about on this mail list, but they have worked
flawlessly through a number of system reboots of both execute nodes
and the qmaster node.  

We have run into some non-SGE related problems around the NFS
implementation in Mac OSx Leopard but nothing directly related to SGE
and the launchd scripts.

Bill


On Wed, Mar 11, 2009 at 09:09:25PM -0700, ron wrote:
>I am 100% sure that one can run qmaster and execd on the same host.
>
>The problem you encountered may be due to the older installation's rc startup scripts. You may want to delete them if they are not in use anymore.
>
><A bit off topic>
>IMO, our Mac startup scripts are a bit out-dated. We had some startup item scripts for earlier OSX versions. Then Apple switched to launchd, and we have not tested the launchd scripts from the BioTeam yet.
>
>Would be great if people here can provide a definitive answer of "yes it works" or "no, xx does not work". If we can find a few YESes, then I will check the launchd scripts into cvs so that it will be included for the next release!
></A bit off topic>
>
> -Ron
>
>
>--- On Sat, 3/7/09, jlforrest <jlforrest at berkeley.edu> wrote:
>> I'm working on installing SGE 6.2u1 on a bunch
>> of high end Mac Pros running OS X 10.5.6.
>> I'm using the "courtesy binaries" from
>> http://gridengine.sunsource.net/downloads/latest.html .
>> 
>> I've got qmaster running on the machine that's
>> also the Open Directory server. This is a dual
>> quad-core machine with 6GB of RAM so it still
>> has lots of umph left over so I tried
>> to install execd on it. Unfortunately the
>> install fails with the following error
>> message:
>> 
>> Specified cluster name
>> >$SGE_CLUSTER_NAME=jones-cluster< resulted in the
>> following conflict!
>> Detected a presence of old RC scripts.
>> /Library/StartupItems/SGE.jones-cluster/SGE
>> 
>> 
>> Stop the installation (WARNING: selecting 'n' will
>> remove the detected cluster) (y/n) [y] >>
>> 
>> Is there a way to run qmaster and execd on the same host?
>> 
>> Cordially,
>> -- 
>> Jon Forrest
>> Research Computing Support
>> College of Chemistry
>> 173 Tan Hall
>> University of California Berkeley
>> Berkeley, CA
>> 94720-1460
>> 510-643-1032
>> jlforrest at berkeley.edu
>> 
>> ------------------------------------------------------
>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=122416
>> 
>> To unsubscribe from this discussion, e-mail:
>> [users-unsubscribe at gridengine.sunsource.net].
>
>------------------------------------------------------
>http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=128121
>
>To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=128451

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list