[GE users] Configure all.q help

icaci hristo at mc.phys.uni-sofia.bg
Tue Mar 17 06:11:04 GMT 2009


Hi,

On 17.03.2009, at 02:12, allantran wrote:

> Hi all,
> I just noticed on the all.q: total slot=64, which is not right (I  
> think??)
> I have:
> 4 x 8 core nodes, name this group @newnodes, total slot = 32
> 4 x 4 core nodes, @oldnodes, total slot = 14

Isn't that 16 for @oldnodes? :)

> When I configure the all.q, my host group box contains @newnodes and
> @oldnodes
> Here is part of my qconf -sq all.q
> qname                 all.q
> hostlist              @oldnodes @newnodes
> seq_no                0
> load_thresholds       np_load_avg=1.75
> suspend_thresholds    NONE
> nsuspend              1
> suspend_interval      00:05:00
> priority              0
> min_cpu_interval      00:05:00
> processors            UNDEFINED
> qtype                 BATCH INTERACTIVE
> ckpt_list             NONE
> pe_list               make
> rerun                 FALSE
> slots                 8

slots is per queue instance hence 8 instances * 8 slots gives 64 slots  
in total. You should modify 'slots' like:

slots                  8,[@oldnodes=4]

You can also achieve this in by adding specific configuration for the  
@oldnodes group and setting slots to 4 for this specific configuration.

>
> Am I not doing something right? Thanks guys.

Hope that helps,

Hristo

>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=133814
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net 
> ].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=134035

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list