[GE users] question/problem with queue assignments and PE jobs

cjf001 john.foley at motorola.com
Wed May 6 15:58:38 BST 2009


Well, I turned on the PROFILE and MONITOR params for the scheduler, so
my now qconf -msconf looks like this:

> algorithm                         default
> schedule_interval                 0:0:15
> maxujobs                          0
> queue_sort_method                 seqno
> job_load_adjustments              np_load_avg=0.50
> load_adjustment_decay_time        0:7:30
> load_formula                      np_load_avg
> schedd_job_info                   true
> flush_submit_sec                  0
> flush_finish_sec                  0
> params                            PROFILE=1,MONITOR=1
> reprioritize_interval             0:0:0
> halftime                          168
> usage_weight_list                 cpu=1.000000,mem=0.000000,io=0.000000
> compensation_factor               5.000000
> weight_user                       0.250000
> weight_project                    0.250000
> weight_department                 0.250000
> weight_job                        0.250000
> weight_tickets_functional         0
> weight_tickets_share              0
> share_override_tickets            TRUE
> share_functional_shares           TRUE
> max_functional_jobs_to_schedule   200
> report_pjob_tickets               TRUE
> max_pending_tasks_per_job         50
> halflife_decay_list               none
> policy_hierarchy                  OFS
> weight_ticket                     0.000000
> weight_waiting_time               0.000000
> weight_deadline                   3600000.000000
> weight_urgency                    0.000000
> weight_priority                   400.000000
> max_reservation                   0
> default_duration                  INFINITY

however, the common/schedule file just gets a bunch of ":"s in it - nothing else.
The spool/qmaster/messages file gets a bunch of stuff, mostly timing details,
it looks like. I couldn't decifer anything in there that looks like the "why"
behind the scheduler's decisions.  Is there any other way to get debug output
from the scheduler ?



John Foley wrote:

> Well, it certainly *looks* like my issue, but either it's not the
> issue I'm seeing, or it really wasn't fixed in 6.2u2 (as Richard
> mentioned).
> 
> I tried the workaround of raising the sequence numbers of the
> queues to very high numbers (1500 and 3000) but still see the
> same thing.
> 
> To answer Daniel's question, I checked to make sure (!) and
> yes, the standard_pe is referenced in both the primary and
> secondary queues.
> 
> So, next question is, I guess, is there any debugging or other
> option that can be turned on to figure out why the scheduler is
> making this decision ? From looking at the sge_conf man page,
> it looks like this is possible using the qconf -msconf command
> and modifying the "params" field, but I thought I'd better
> check here first to see if that's the best way to do it (or if
> that actually will accomplish what I'm looking for). If this
> is the best way, could someone show an example of using that
> command ?
> 
>     Thanks,
> 
>       John
> 
> 
> rems0 wrote:
> 
>> olesen wrote:
>>
>>> It looks to me like you are hitting this issue:
>>>
>>> http://gridengine.sunsource.net/issues/show_bug.cgi?id=2864
>>
>>
>>
>> I'm also hitting this issue, but I'm using GE 6.2u1.
>> John is using GE 6.2u2, and this issue status is marked as RESOLVED and
>> FIXED for 6.2u2 !
>> Apparently it's not fixed at all! Or did I misunderstood the "Target
>> milestone" tag?
>> Andreas?
>>
>> Thanks, Richard
>>
>>
>>
> 
> 
> 



-- 
###########################################################################
# John Foley                          # Location:  IL93-E1-21S            #
# IT & Systems Administration         # Maildrop:  IL93-E1-35O            #
# Antenna & Mechanical Simulation Grp #    Email: john.foley at motorola.com #
# Motorola, Inc. -  Mobile Devices    #    Phone: (847) 523-8719          #
# 600 North US Highway 45             #      Fax: (847) 523-5767          #
# Libertyville, IL. 60048  (USA)      #     Cell: (847) 460-8719          #
###########################################################################
                 (this email sent using Mozilla on Windows)

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=191715

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list