[GE users] where does 'qsh' get the path to xterm from if it does not honor the xterm parameter in qmaster config?

craffi dag at sonsorol.org
Mon May 18 22:40:58 BST 2009


Hi folks,

I've got a ROCKS cluster with nodes that I can knock offline into E  
state with a simple 'qsh' command.

The first root cause was xterm not being install on the compute nodes.  
The current problem is SGE being unable to find the xterm binary.

The problem is that qsh does not seem to be honoring the path for  
xterm set in the qmaster configuration:

With these settings:

> $ which xterm
> /usr/bin/xterm
>

> $ qconf -sconf | grep xterm
> xterm                        /usr/bin/xterm
>


I still get this error:

> 05/18/2009 17:34:33|qmaster|albert|W|job 37.1 failed on host  
> compute-0-10.local general before job because: 05/18/2009 17:34:32  
> [511:15454]: unable to find xterm executable "/usr/bin/X11/xterm"  
> for interactive job
> 05/18/2009 17:34:33|qmaster|albert|E|queue all.q marked QERROR as  
> result of job 37's failure at host compute-0-10.local
>


I know I've seen this in the past and I've simply worked around it via  
a symbolic link, I don't want to do that anymore.

Can anyone give me a hint on why SGE is still trying to use the "/usr/ 
bin/X11/xterm" when the configured path in the qmaster configuration  
is "/usr/bin/xterm" ?

Not sure if this is set somewhere else or if SGE is really not  
honoring the configured value. Any tips appreciated.

-Chris

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=197185

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list