Fwd: [GE users] SGE over yellowdog PS3

jigzat jigzat at gmail.com
Mon May 25 23:01:52 BST 2009


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Ok I just re-download the source from the cvs and made some of the suggested changes and I'm getting the libpam errror.

I downloaded and build the souce of Linux-PAM-1.0.4 but I keep getting the same error. Then I try to configure it with the CC="gcc -m64" but after executing make I get this:

pam_conv_l.o: In function `yylex':
/root/Desktop/Linux-PAM-1.0.4/conf/pam_conv1/pam_conv_l.c:843: undefined reference to `yywrap'
collect2: ld returned 1 exit status
make[4]: *** [pam_conv1] Error 1
make[4]: se sale del directorio `/root/Desktop/Linux-PAM-1.0.4/conf/pam_conv1'
make[3]: *** [all] Error 2
make[3]: se sale del directorio `/root/Desktop/Linux-PAM-1.0.4/conf/pam_conv1'
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/root/Desktop/Linux-PAM-1.0.4/conf'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/root/Desktop/Linux-PAM-1.0.4'
make: *** [all] Error 2

Any ideas?


2009/5/25 Samir Gartner <jigzat at gmail.com<mailto:jigzat at gmail.com>>
Hi Ron, I just checked that I am properly subscribed and yes I am receiving emails but I checked my thread under the forums topic index and i have 4 messages under "pending aproval" I don't know the reason maybe a bug but It has happened since the first time I joined in. My first message got delayed and it was keept under pending aprobal for a while. Or maybe I am whining to much about the standar delays... am I? I did made a mistake the first time I answered the first response and send it first to Ray so maybe it is all my fault.

2009/5/25 Ron Chen <ron_chen_123 at yahoo.com<mailto:ron_chen_123 at yahoo.com>>


Samir,

Make sure you are properly subscribed to the list. Are you getting emails from the list?

If you are not subscribed to the list and you send email to the list, I think the SGE developers will need to filter your messages by hand, and it is slow.

And, ALWAYS send discussions to the list, as 1) someone else may know the answer, 2) the individuals that you send mails to are not paid to fix the problems you encounter. (I am a bad example of sending email to individual, but I am just making sure that you get the message as I am not sure if you are subscribed to list.)


For the problem with ssl libraries, you need to pick up this aimk fix that I checked into cvs a few months ago:

http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=35&dsMessageId=122677

And for pam library, you will need to build your own libpam in 64-bit.

 -Ron


--- On Tue, 5/26/09, Rayson Ho <rayrayson at gmail.com<mailto:rayrayson at gmail.com>> wrote:
> Any reason why the list is not
> accepting his emails??
>
> Rayson
>
>
>
> ---------- Forwarded message ----------
> From: Samir Gartner <jigzat at gmail.com<mailto:jigzat at gmail.com>>
> Date: May 25, 2009 1:47 PM
> Subject: Re: [GE users] SGE over yellowdog PS3
> To: Rayson Ho <rayrayson at gmail.com<mailto:rayrayson at gmail.com>>
>
>
> I did send it to the list first Ray, in fact your copy was
> a resent.
> For some reason the list doesn't seem to be sending my
> emails to you.
>
> 2009/5/25 Rayson Ho <rayrayson at gmail.com<mailto:rayrayson at gmail.com>>
>
> > Again, to the list please!
> >
> >
> >
> >
> >
> > On 5/25/09, Samir Gartner <jigzat at gmail.com<mailto:jigzat at gmail.com>>
> wrote:
> > >
> > >
> > > ---------- Forwarded message ----------
> > > From: Samir Gartner <jigzat at gmail.com<mailto:jigzat at gmail.com>>
> > > Date: 2009/5/25
> > > Subject: Re: [GE users] SGE over yellowdog PS3
> > > To: users <users at gridengine.sunsource.net<mailto:users at gridengine.sunsource.net>>
> > >
> > >
> > > hey thaks again Rayson, I got a little further.
> This is the final output:
> > > it's weird since as far as I know -no-secure
> forces aimk to not use openssl.
> > > Of course that is not openssl folder in YDL
> > >
> > >
> > > gcc:
> > >
> /off_home/gridengine/openssl-0.9.8h-origin/lx26-ppc64/lib/libssl.a:
> > > No existe el fichero o el directorio
> > > gcc:
> > >
> /off_home/gridengine/openssl-0.9.8h-origin/lx26-ppc64/lib/libcrypto.a:
> > > No existe el fichero o el directorio
> > > make: *** [sge_shepherd] Error 1
> > >
> > > So I changed openSSL home for /usr (/usr/lib
> didn't worked out) and it went
> > > further but now I'm geting this and I'm lost:
> > >
> > >
> > > /usr/bin/ld: skipping incompatible
> /usr/lib/libpam.so when searching for
> > > -lpam
> > > /usr/bin/ld: cannot find -lpam
> > >
> > > collect2: ld devolvió el estado de salida 1
> > > make: *** [authuser] Error 1
> > > not done
> > >
> > >
> > >
> > > 2009/5/25 rayson <rayrayson at gmail.com<mailto:rayrayson at gmail.com>>
> > >
> > >
> > > >
> > > > In theory, LINUXPPC64 is already excluded
> from linking against -lint,
> > > > but you can double check and might need to
> hand modify aimk as
> > > > described in:
> > > >
> > > >
> > > http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=155049
> > > >
> > > > Rayson
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > On 5/25/09, Samir Gartner <jigzat at gmail.com<mailto:jigzat at gmail.com>>
> wrote:
> > > > > I installed gettext-devel and intltool
> but I'm getting the same output.
> > > I
> > > > > was thinking about removing the flag
> from aimk the same way as Werror
> > > but
> > > > > I'm not sure if is the wisest thing to
> do. Is there any other package
> > > that
> > > > > contains lintl? and what exactly is
> it?
> > > > >
> > > > > I saw a guy on the mailing list with
> the same problem but under SPARC
> > > but
> > > > > the thread didn't said how he solved
> it.
> > > > >
> > > > > 2009/5/25 Samir Gartner <jigzat at gmail.com<mailto:jigzat at gmail.com>>
> > > > > > Nothing yet.
> > > > > >
> > > > > > This is the end of output,
> there was nothing out of the ordinary
> > > before
> > > > > this:
> > > > > >
> > > > > > /usr/bin/ld: cannot find -lintl
> > > > > > collect2: ld devolvió el estado
> de salida 1     <<< This means
> > > something
> > > > > ld returned like exit state 1
> > > > > > make: *** [test_sge_object] Error
> 1
> > > > > > not done
> > > > > >
> > > > > > Should I put the rest of the
> output?
> > > > > >
> > > > > >
> > > > > >
> > > > > > 2009/5/24 rayson <rayrayson at gmail.com<mailto:rayrayson at gmail.com>>
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > >
> > > > > > > Yes, it's related gcc
> treating warnings as errors. You can remove
> > > > > > > "-Werror" from the CFLAGS in
> aimk (around line 1361).
> > > > > > >
> > > > > > > I think we will add a new
> aimk flag to disable treating warnings as
> > > > > > > errors in future.
> > > > > > >
> > > > > > > Rayson
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > On 5/24/09, Samir Gartner
> <jigzat at gmail.com<mailto:jigzat at gmail.com>>
> wrote:
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > > Hey Rayson thanks for
> the answer. I tried to build sge with your
> > > > > > > > instructions both with
> java and without it but I couldn't,
> > > although
> > > > > the
> > > > > > > > output is different. I
> think it has something to do with
> > > > > > > > --disable-gcc-warnings
> using that option with ./configure allowed
> > > me
> > > > > to
> > > > > > > > built torque under
> YDL/PS3 it was also necessary to build it under
> > > Mac
> > > > > OS X,
> > > > > > > > but I don't know how to
> enable that under aimk.... I mean if that
> > > is
> > > > > the
> > > > > > > > problem.
> > > > > > > >
> > > > > > > > This is the output:
> > > > > > > >
> > > > > > > > The spanish errors at
> the end means something about "breaking the
> > > law
> > > > > of
> > > > > > > > strict alias" but it's
> baddly translated to spanish so I'm not
> > > quite
> > > > > sure
> > > > > > > > how to translate it
> back.
> > > > > > > >
> > > > > > > > ../common -I../libs
> -I../libs/uti -I../libs/juti -I../libs/gdi
> > > > > > > > -I../libs/japi
> -I../libs/sgeobj -I../libs/cull -I../libs/rmon
> > > > > -I../libs/comm
> > > > > > > > -I../libs/comm/lists
> -I../libs/sched -I../libs/evc -I../libs/evm
> > > > > > > > -I../libs/mir
> -I../libs/lck -I../daemons/common
> > > -I../daemons/qmaster
> > > > > > > > -I../daemons/execd
> -I../daemons/schedd -I../clients/common -I.
> > > -fPIC
> > > > > -c
> > > > > > > >
> ../libs/uti/sge_bootstrap.c
> > > > > > > ...
> > > > > > > > gcc -O3 -Wall -Werror
> -Wstrict-prototypes -DUSE_POLL -DLINUX
> > > > > -DLINUXPPC64
> > > > > > > > -DLINUXPPC64_26
> -D_GNU_SOURCE -DGETHOSTBYNAME_R6
> > > -DGETHOSTBYADDR_R8
> > > > > -m64
> > > > > > > >
> -I/usr/loca/BerkeleyDB.4.7/include/
> > > > > > > >
> -DSGE_ARCH_STRING=lx26-ppc64 -DTARGET_64BIT
> -DSPOOLING_classic
> > > > > -DNO_JNI
> > > > > > > > -DCOMPILE_DC
> -D__SGE_COMPILE_WITH_GETTEXT__
> > > > > > > >
> > > > >
> > >
> -I/usr/local/src/gridengine/source/3rdparty/gettext/LINUXPPC64/include
> > > > > > > > -D__SGE_NO_USERMAPPING__
> -I../common -I../libs -I../libs/uti
> > > > > -I../libs/juti
> > > > > > > > -I../libs/gdi
> -I../libs/japi -I../libs/sgeobj -I../libs/cull
> > > > > -I../libs/rmon
> > > > > > > > -I../libs/comm
> -I../libs/comm/lists -I../libs/sched -I../libs/evc
> > > > > > > > -I../libs/evm
> -I../libs/mir -I../libs/lck -I../daemons/common
> > > > > > > > -I../daemons/qmaster
> -I../daemons/execd -I../daemons/schedd
> > > > > > > > -I../clients/common -I.
> -fPIC -c
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > >
> ../libs/comm/cl_connection_list.c
> > > > > > > >
> > > > > > > > cc1: warnings being
> treated as errors
> > > > > > > >
> ../libs/comm/cl_connection_list.c: In function
> > > > > > > >
> ?cl_connection_list_remove_connection?:
> > > > > > > >
> ../libs/comm/cl_connection_list.c:214: aviso: la
> > > > > > > > dereferencia de punteros
> de tipo castigado romperá las reglas de
> > > alias
> > > > > > > > estricto
> > > > > > > >
> ../libs/comm/cl_connection_list.c: In function
> > > > > > > >
> ?cl_connection_list_get_elem_endpoint?:
> > > > > > > >
> ../libs/comm/cl_connection_list.c:581: aviso: la
> > > > > > > > dereferencia de punteros
> de tipo castigado romperá las reglas de
> > > alias
> > > > > > > > estricto
> > > > > > > > make: ***
> [cl_connection_list.o] Error 1
> > > > > > > > not done
> > > > > > > >
> > > > > > > >
> > > > > > > > Apparently I need Java
> according to the Globus Tutorial. The
> > > > > instructions
> > > > > > > > recommend to remove the
> default Java Installation that comes with
> > > > > Fedora and
> > > > > > > > install Sun's
> Distribution but there's no Sun's Java official
> > > > > distribution
> > > > > > > > for YellowDog, not even
> for PowerPC ..... am I right?
> > > > > > > >
> > > > > > > > 2009/5/23 Rayson Ho
> <rayrayson at gmail.com<mailto:rayrayson at gmail.com>>
> > > > > > > > > This is because
> your Java related path settings are not set up
> > > > > > > > >
> > > > > > > > > properly in
> aimk.site. To build SGE without the external
> > > > > dependencies,
> > > > > > > > > you can try the
> following steps:
> > > > > > > > >
> > > > > > > > > 1) ./aimk -no-dump
> -only-depend
> > > > > > > > > 2)
> scripts/zerodepend
> > > > > > > > > 3) ./aimk -no-dump
> depend
> > > > > > > > > 4) ./aimk -no-dump
> -no-jni -no-java -no-secure -spool-classic
> > > > > > > > >
> > > > > > > > > However, if you
> need the DRMAA Java binding, you will need to
> > > take
> > > > > > > > > away the "-no-jni
> -no-java" flags in step 4, and install a JVM
> > > and
> > > > > the
> > > > > > > > > Java compiler, dev
> libraries, and include files (mainly jni.h).
> > > > > > > > >
> > > > > > > > > Let me know if you
> encounter other problems...
> > > > > > > > >
> > > > > > > > > Rayson
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > >
> > > > > > >
> > >
> ------------------------------------------------------
> > > > > > >
> > > > >
> > > http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=198771
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > To unsubscribe from this
> discussion, e-mail:
> > > > > [users-unsubscribe at gridengine.sunsource.net<mailto:users-unsubscribe at gridengine.sunsource.net>].
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> ------------------------------------------------------
> > > >
> > > http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=198847
> > > >
> > > >
> > > >
> > > >
> > > > To unsubscribe from this discussion,
> e-mail:
> > > [users-unsubscribe at gridengine.sunsource.net<mailto:users-unsubscribe at gridengine.sunsource.net>].
> > > >
> > >
> > >
> > >
> >
>








More information about the gridengine-users mailing list