[GE users] running magma / talus in SGE with qrsh

adary adary at marvell.com
Wed May 27 14:09:11 BST 2009


    [ The following text is in the "Windows-1252" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi folks,

I ran into an interesting ?feature? and I was wondering if anyone else experienced something similar, or if anyone even has a solution.

In our daily work we run a lot of shell jobs through qrsh

On our 6.1u3 implementation all interactive jobs went over ssh, and with a little tweaking we got to the point where all shell applications running through qrsh are properly catching ^C, and handling it the way they are supposed to handle it (break execution in pt_shell, prompt in magma/talus ?)

When we tested the same applications in 6.2u2 over qrsh, but without the ssh layer (we used the built in) all application behaved as expected except magma tools. They just ignore ^C as if nothing was pressed.

Any ideas ?

________________________________
Yuval Adar, Marvell Israel - Senior UNIX System Administrator
6 Hamada Street
Mordot HaCarmel Industrial Park
Yokneam, 20692, Israel
Email: adary at marvell.com<mailto:adary at marvell.com>
Office:  +972.4.9091188 - OnNet: 704.1188
Fax:      +972.4.9091501
Mobile: +972.54.2493958
Web site: http://www.marvell.com<http://www.marvell.com/>

This message may contain confidential, proprietary or legally privileged information. The information is intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by telephone or by e-mail and delete the message from your computer.
________________________________




More information about the gridengine-users mailing list