[GE users] Run qlicserver As A True Daemon

butters chris at pearit.co.uk
Fri May 29 09:48:15 BST 2009


Hi Mark,

Thanks for the help, I hadn't spotted the 'ppid' parameter!
So, I started with a clean qlicserver file and tried as you suggested, and it worked - qlicserver now runs correctly as a daemon, and the output issue disappeared as well.
In case it's of any use to anyone, here's the init script I'm using;

-------------------------------------------
#!/bin/bash -l
# Use a login shell to make sure all as much of the standard environment as possible is automaically setup

# Even though both this environment variables are imported by using 'bash -l', I found I had to set them explicitly here as well for qlicserver to work
export SGE_CELL=default
export SGE_ROOT=/data/sge

# Store path to qlicserver directory
FP=/data/flex-grid/matlab

if [ -x $FP/qlicserver ]; then
        $FP/qlicserver -d ppid=0 output=$FP/qlicserver.cache
fi
-------------------------------------------

Thanks everyone for your help,
Chris

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=199641

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list