[GE users] qlicserver seems to double subtract

biscisking dsmith03 at its.jnj.com
Mon Nov 2 14:43:51 GMT 2009


As I was leaving for the day, I realized exactly what you're saying.  I'm circumventing qlicserver's desired behavior.  To confirm, I ran an experiment where I had two jobs in qw for insufficient licenses, and then killed a running job that would release enough licenses for only one of the two to run.  As I'm sure you're predicting, they both ran at the instant the abaqus complex value became sufficient.  Naturally, one got stuck in the license queue, which is the exact behavior I'm trying to avoid.

Your suspicions are correct that I did not tell qlicserver that it was type="job".  I see that it's written that way in the latest version of qlicserver, but in the version I was using it was not.  I did not edit that line.  I'll try that change.  That being said, I had the same thing for the abaqus complex you have listed when I experienced the "double subtraction."  The scenario was definitely not correct.  If I had 14 licenses, like in your example, and I requested 6 for a job, qstat -F abaqus would show me that only 2 were available (14-2*6), and if I submitted another job requiring 6, it would go into qw status and not come out, even though there were actually 8 licenses available.

There's one other thing I tried, and that was to set consumable=YES and have the -l abaqus= line scale the requested number.  This is working.  Funny thing is, now qstat -F abaqus gives gc instead of gf.  Not sure how that happened, and I can't find the meanings of gc or gf to get a clue.  Also interestingly, it's working correctly despite the fact that I do not have type="job" in qlicserver.

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=224626

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list