[GE users] critical error: !!!!!!!!!! Nameindex = 137101 not found in element !!!!!!!!!!

petrik lubomir.petrik at sun.com
Thu Nov 12 17:00:34 GMT 2009


Good. I'll update the upgrade instructions to warn about this problem 
which I imagine could be quite common on some platforms.

Lubos.

j_polasek wrote:
> Thanks Lubos!!  That did the trick.  The clone update ran perfectly.  Now to test the environments.
>
> Jeff
>
> On Nov 12, 2009, at 9:04 AM, petrik wrote:
>
>   
>> Ok, then you had in your environment the DYLD_LIBRARY_PATH pointing to 
>> the old libraries and it was used when upgrading. Unset this variable 
>> before starting the upgrade process and of course revert back to your 
>> inst_qmaster.sh file.
>>
>> Let us know, if you succeeded.
>>
>> Lubos.
>>
>> j_polasek wrote:
>>     
>>> Hi Lubos,
>>>
>>> Thanks for the help.  I wasn't clear, neither spooling method will 
>>> work, both give the same type error (i don't remember if the element 
>>> number is the same or not).
>>>
>>> Unfortunately the change didn't help.  I get the following error when 
>>> running the modified script.
>>>
>>> Initializing spooling database
>>> critical error: !!!!!!!!!! Nameindex = 137101 not found in element 
>>> !!!!!!!!!!
>>> ./util/install_modules/inst_qmaster.sh: line 774: 57403 Abort trap     
>>>         $SPOOLINIT $SPOOLING_METHOD $SPOOLING_LIB "$SPOOLING_ARGS" init
>>>
>>> Hit <RETURN> to continue >> 
>>>
>>> but it lets me continue.  I answer yes to importing the interactive 
>>> run info, and then i get the following error
>>>
>>> dyld: Symbol not found: _AH_fields
>>>  Referenced from: /common/sge6.2/./utilbin/darwin-x86/spooldefaults
>>>  Expected in: /common/sge/lib/darwin-x86/libspoolc.dylib
>>>
>>> ./util/install_modules/inst_common.sh: line 243: 13716 Trace/BPT trap 
>>>         $SGE_UTILBIN/adminrun $ADMINUSER "$@"
>>>
>>> Command failed: ./utilbin/darwin-x86/spooldefaults configuration 
>>> /tmp/configuration_2009-11-12_08:07:02.17608
>>>
>>> Probably a permission problem. Please check file access permissions.
>>> Check read/write permission. Check if SGE daemons are running.
>>>
>>> Any idea why it is looking in the original sge (6.1 version) directory 
>>> rather than the sge6.2 (6.2 version) directory for libspoolc.dylib?
>>>
>>> Thanks
>>>
>>> Jeff
>>>
>>>
>>>  	  	  	  	  	  	  	  	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>> 	
>>>
>>> On Nov 11, 2009, at 4:49 PM, petrik wrote:
>>>
>>>       
>>>> Hi Jeff,
>>>> I remember seeing this once, but not during an upgrade (during an
>>>> installation). I don't know what is causing it but I think following
>>>> should solve it for you.
>>>>
>>>> Change the InitSpoolingDatabase() in
>>>> ./util/install_modules/inst_qmaster.sh so that it doesn't call
>>>> ExecuteAsAdmin and instead it calls spoolinit as root and sets relevant
>>>> file permissions after that.
>>>> e.g.: ExecuteAsAdmin $SPOOLINIT $SPOOLING_METHOD $SPOOLING_LIB
>>>> "$SPOOLING_ARGS" init
>>>> to
>>>> $SPOOLINIT $SPOOLING_METHOD $SPOOLING_LIB "$SPOOLING_ARGS" init
>>>> chown -R $ADMINUSER:<admin_user's_group> /common/sge6.2/default/common
>>>> chown -R $ADMINUSER:<admin_user's_group>
>>>> /common/sge6.2/default/spool/qmaster
>>>>
>>>> Let me know if this worked for you.
>>>>
>>>> Regards,
>>>>  Lubos.
>>>>
>>>> PS: My suggestion will not work if root cannot write to
>>>> /common/sge6.2/default.
>>>> PPS: Just to be clear you are saying that with bdb it works, but not
>>>> when you choose classic, right?
>>>>
>>>>
>>>> j_polasek wrote:
>>>>         
>>>>> Howdy all,
>>>>>
>>>>> I am in the process of attempting to update an SGE  6.1u6 OS X 10.5 
>>>>> cluster (that I didn't instal)  to 6.2U4.  I am using the "cloned 
>>>>> cluster configuration"method as listed in 
>>>>> http://wikis.sun.com/display/GridEngine/Upgrading+Sun+Grid+Engine+Software#UpgradingSunGridEngineSoftware-dobackup
>>>>>
>>>>> Everything works like it should up until I choose the "classic" 
>>>>> spooling method (not BDB).  I get the following error:
>>>>>
>>>>> Initializing spooling database
>>>>> critical error: !!!!!!!!!! Nameindex = 137101 not found in element 
>>>>> !!!!!!!!!!
>>>>> ./util/install_modules/inst_common.sh: line 243: 52505 Abort trap 
>>>>>             $SGE_UTILBIN/adminrun $ADMINUSER "$@"
>>>>>
>>>>> Command failed: ./utilbin/darwin-x86/spoolinit classic libspoolc 
>>>>> /common/sge6.2/default/common;/common/sge6.2/default/spool/qmaster init
>>>>>
>>>>> Probably a permission problem. Please check file access permissions.
>>>>> Check read/write permission. Check if SGE daemons are running.
>>>>>
>>>>> The SGE daemons are not running and I let the script reset the 
>>>>> permissions earlier in the install script.  
>>>>>
>>>>> The admin user is sge and owns the directories and has full rw 
>>>>> permissions.
>>>>>
>>>>> I have not been able to find anything about this in the archives.
>>>>>
>>>>> Anyone have any hints to get me over this hump??
>>>>>
>>>>> Thanks
>>>>>
>>>>> Jeff
>>>>>
>>>>> Jeff Polasek
>>>>> systems manager
>>>>> Chemical Engineering
>>>>> TAMU
>>>>>
>>>>> ------------------------------------------------------
>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226231 
>>>>> <http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226231>
>>>>>
>>>>> To unsubscribe from this discussion, e-mail: 
>>>>> [users-unsubscribe at gridengine.sunsource.net].
>>>>>
>>>>>           
>>>> ------------------------------------------------------
>>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226264 
>>>> <http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226264>
>>>>
>>>> To unsubscribe from this discussion, e-mail: 
>>>> [users-unsubscribe at gridengine.sunsource.net].
>>>>
>>>>
>>>>         
>> ------------------------------------------------------
>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226463
>>
>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>>
>>
>>     
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226469
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=226478

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list