[GE issues] [Issue 3183] New - wrong qhost help output regarding topology based information switch

crei crei at sun.com
Tue Nov 17 11:01:28 GMT 2009


http://gridengine.sunsource.net/issues/show_bug.cgi?id=3183
                 Issue #|3183
                 Summary|wrong qhost help output regarding topology based infor
                        |mation switch
               Component|gridengine
                 Version|6.2u5alpha
                Platform|Sun
                     URL|
              OS/Version|All
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|clients
             Assigned to|roland
             Reported by|crei






------- Additional comments from crei at sunsource.net Tue Nov 17 03:01:25 -0800 2009 -------
The qhost -help output describes the parameter -cq as following:
# qhost -help
SGE 6.2u5alpha2 (build 20091117)
usage: qhost [options]
  [-cq]                      show topology based information (socket/core)
  [-help]                    print this help
  [-h hostlist]              display only selected hosts
  [-q]                       display queues hosted by host
  [-j]                       display jobs hosted by host
  [-l attr=val,...]          request the given resources
  [-F [resource_attribute]]  show (selected) resources
  [-u user[,user,...]]       show only jobs for user
  [-xml]                     display the information in XML-Format

But when doing an invalid option argument error is shown:

# qhost -cq
SGE 6.2u5alpha2 (build 20091117)
usage: qhost [options]
  [-cq]                      show topology based information (socket/core)
  [-help]                    print this help
  [-h hostlist]              display only selected hosts
  [-q]                       display queues hosted by host
  [-j]                       display jobs hosted by host
  [-l attr=val,...]          request the given resources
  [-F [resource_attribute]]  show (selected) resources
  [-u user[,user,...]]       show only jobs for user
  [-xml]                     display the information in XML-Format
error: ERROR! invalid option argument "-cq"

The correct parameter name is "-cb":

# qhost -cb
HOSTNAME                ARCH         NCPU NSOC NCOR  LOAD  MEMTOT  MEMUSE  SWAPTO  SWAPUS
-----------------------------------------------------------------------------------------
global                  -               -    -    -     -       -       -       -       -
foo                     lx26-amd64      2    1    2  0.29    3.9G  565.6M    2.0G     0.0

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=36&dsMessageId=227429

To unsubscribe from this discussion, e-mail: [issues-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list