[GE users] Cannot add Execution host! "Obviously there was no qmaster installation yet!"

petrik lubomir.petrik at sun.com
Wed Nov 18 10:22:43 GMT 2009


And that is the correct output that should allow installation of execd 
without any modifications :-).

If you are able (and willing) to find out the reason, let us know.

Regards,
   Lubos.

umanga wrote:
> Hi Lubos,
>
> Thank for the reply,my output was:
>
> cd $SGE_ROOT
> + cd /SGE6/sge6.2/
> test -f default/common/act_qmaster
> + test -f default/common/act_qmaster
> echo $?
> + echo 0
> 0
> ls default/common/act_qmaster
> + ls default/common/act_qmaster
> default/common/act_qmaster
>
>
> Best Regards
>
> petrik wrote:
>> Well,
>> the thing is that it should work fine even without that! Can you send me 
>> the output of the below commands.
>>
>> Thanks,
>>    Lubos.
>>
>> umanga wrote:
>>   
>>> Hi Lubos,
>>>
>>> I inserted a new line to "/util/install_modules/inst_execd.sh" as
>>>
>>> COMMONDIR=$SGE_ROOT/$COMMONDIR
>>>
>>> Now it works fine.
>>>
>>> Thanks
>>> petrik wrote:
>>>     
>>>> Ok,
>>>> what does following return on that host?
>>>>
>>>> cd $SGE_ROOT
>>>> test -f default/common/act_qmaster
>>>> echo $?
>>>> ls default/common/act_qmaster
>>>>
>>>> Lubos.
>>>>
>>>> umanga wrote:
>>>>   
>>>>       
>>>>> Hi Lubos,
>>>>>
>>>>> Thanks for the tip,
>>>>> yes cell name is 'default' and I have set SGE_ROOT properly.
>>>>>
>>>>> During installation i noticed that COMMONDIR variable missing the 
>>>>> SGE_ROOT part,
>>>>> is it correct ? Is it suppose to be a relative directory or absolute 
>>>>> one like
>>>>> COMMONDIR=/SGE6/sge6.2/default/common ?
>>>>>
>>>>> Here is the output :
>>>>>
>>>>> +COMMONDIR=default/common
>>>>> + LCONFDIR=default/common/local_conf
>>>>> + CASHAREDDIR=default/common/sgeCA
>>>>> + '[' '!' -f default/common/act_qmaster -o '!' -f 
>>>>> default/common/bootstrap ']'
>>>>> + ./utilbin/lx24-x86/infotext '\nObviously there was no qmaster 
>>>>> installation yet!\nCall >install_qmaster<\n' 'on the machine which 
>>>>> shall run the Grid Engi
>>>>>
>>>>>
>>>>> petrik wrote:
>>>>>     
>>>>>         
>>>>>> i,
>>>>>> are you sure you entered the correct SGE_CELL? You could always run the 
>>>>>> script with debug to see what act_qmaster and what bootstrap file the 
>>>>>> installer really tries to access (e.g.: bash -vx ./inst_sge -x). If you 
>>>>>> cannot figure out what is wrong post several last lines before you get 
>>>>>> the error message (since it enters the CheckQmasterInstallation()).
>>>>>>
>>>>>> Regards,
>>>>>>    Lubos.
>>>>>>
>>>>>> umanga wrote:
>>>>>>   
>>>>>>       
>>>>>>           
>>>>>>> Greetings all,
>>>>>>>
>>>>>>> I have shared /SGE6/sge6.2 using NFS where every execution host and 
>>>>>>> qmaster can access the folder.
>>>>>>> I have two execution hosts running Debian Lenny 64bit and want to add a 
>>>>>>> new machine with Debian Lenny 32bit.
>>>>>>>
>>>>>>> But during "install_execd" it gives the error:
>>>>>>>
>>>>>>> "Obviously there was no qmaster installation yet!
>>>>>>> Call >install_qmaster<
>>>>>>> on the machine which shall run the Grid Engine qmaster"
>>>>>>>
>>>>>>> and stops.
>>>>>>>
>>>>>>> This host also can access /SGE6/sge6.2 and the files "act_qmaster" and 
>>>>>>> "bootstrap " in $SGE_ROOT/$CELL/common folder.
>>>>>>>
>>>>>>> Any tips,
>>>>>>>
>>>>>>> thanks in advance,
>>>>>>> umanga
>>>>>>>
>>>>>>> ------------------------------------------------------
>>>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=227603
>>>>>>>
>>>>>>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>>>>>>>
>>>>>>>     
>>>>>>>         
>>>>>>>             
>>>>>> ------------------------------------------------------
>>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=227611
>>>>>>
>>>>>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>>>>>>   
>>>>>>       
>>>>>>           
>>>> ------------------------------------------------------
>>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=227620
>>>>
>>>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>>>>   
>>>>       
>>
>> ------------------------------------------------------
>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=227629
>>
>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>>   
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=227636

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list