[GE users] cannot run in PE "smp" because it only offers 2 slots

easymf michal.bachorik at sun.com
Fri Sep 11 17:47:03 BST 2009


Sean,

most probably your PE is used only in the queue, that offers 2 slots. 
Check in which queues is the PE used, and whether this queues offers 
enough slots.

For example, my PE named orte:

qconf -sp orte
pe_name            orte
slots              8
user_lists         NONE
xuser_lists        NONE
start_proc_args    /bin/true
stop_proc_args     /bin/true
allocation_rule    $round_robin
control_slaves     TRUE
job_is_first_task  FALSE
urgency_slots      min
accounting_summary FALSE

is used in all.q. if i have just one execd with 2 slots in all.q used, i 
get the same message.

Regards,

Michal

seandavi wrote:
> I have an SGE 6.2 system with several 8-processor smp machines for 
> which we have the "smp" parallel environment:
>
> > qconf -sp smp
> pe_name            smp
> slots              60
> user_lists         NONE
> xuser_lists        NONE
> start_proc_args    /bin/true
> stop_proc_args     /bin/true
> allocation_rule    $pe_slots
> control_slaves     FALSE
> job_is_first_task  FALSE
> urgency_slots      min
> accounting_summary TRUE
>
> Note that it has 60 slots.  qstat shows no jobs running and no error 
> conditions.  I submit the "sleeper.sh" job as just a test:
>
> qsub -pe smp 8 sleeper.sh
>
> qstat -j shows:
>
> parallel environment:  smp range: 8
> scheduling info:            cannot run in PE "smp" because it only 
> offers 2 slots
>
> Any ideas what the issue is? 
>
> Thanks,
> Sean
>
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=216904

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list