[GE users] Job does not lock on exited with 100 error code when submitted using drmaa

levsha i at levsha.org.ua
Thu Sep 17 16:47:45 BST 2009


Hi!
I use 6.2u2_1 on FreeBSD. When i submit job using qsub:

# qsub -b y -shell n sh -c 'exit 100'

all work properly: after running i receive mail "GE 6.2u2_1: Job 2
failed" and job locks in error state:

#qstat
job-ID  prior   name       user         state submit/start at     queue                          slots ja-task-ID 
-----------------------------------------------------------------------------------------------------------------
      2 0.55500 sh         levsha       Eqw   09/17/2009 17:14:31                                    1        

And when i submit job using drmaa (from C program), i receive same mail
"GE 6.2u2_1: Job 3 failed" (i compare messages without timestamps using
diff: only job id, pid and times different), but no job in queue in
error state.

Locking jobs in error state is veery important for me: i submit jobs
jail an want to not start next job when previos failed.

C program source code and error email messages faile attached

-- 
Mykola Dzham, LEFT-(UANIC|RIPE)
JID: levsha at jabber.net.ua

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=217661

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

    [ Part 2, "submit.c"  Text/X-CSRC (Name: "submit.c") ~2.3 KB. ]
    [ Unable to print this part. ]


    [ Part 3, "mail.txt"  Text/PLAIN (Name: "mail.txt") ~8.3 KB. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list