[GE dev] Fw: Re: [GE dev] Rmpi and SGE: issues

hintak htl10 at users.sourceforge.net
Wed Apr 7 03:53:00 BST 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

sent from the wrong account and got bounced.

> There is an Rmpi HOWTO on the
> gridengine community web site, I think; also, you might get
> better response from the R-users or the bioc-users list. 
> 
> In any case, the qsub environment does not inherit many
> user account customizations, so things like R_LIBS,
> MPI_ROOTS, .libPaths, .Rprofile, .Renviron cannot be assumed
> - you need to set most user account customizations within
> your R script, such as library(,lib.loc=..)  
> 
> --- On Thu, 1/4/10, myriad360 <cblair at vandals.uidaho.edu>
> wrote:
> 
> From: myriad360 <cblair at vandals.uidaho.edu>
> Subject: [GE dev] Rmpi and SGE: issues
> To: dev at gridengine.sunsource.net
> Date: Thursday, 1 April, 2010, 18:04
> 
> 
> 
> 
>  I am having issues implementing Rmpi (for the R language)
> with SGE. Our SGE system is up and working well with
> OpenMPI, and programs compiled in C with mpicc spawn across
> all nodes after a qsub. So all that seems to be working as
> expected.
> 
> When running R straight off any node (via mpirun R <
> script.R --no-slave ), Rmpi spawns correctly, but of course
> only on that one node. When submitting to SGE via qsub with
> a submit script, the R program hangs on the Rmpi load in the
> R script (require (Rmpi)). 
> 
> I was curious if any one can give me insight on why this is
> happening, and what I might need to do to get Rmpi working
> correctly with SGE. 
> 
> Thanks everyone,
> 
> Colby
> 
>  
>  
> Contact Info:
> Colby Blair 
> 843 Travois Way
> Moscow, ID 83843
> Cell 1: 1.208.301.1576
> Cell 2: 1.208.631.1059
> 
> IBEST Computing Core - www.ibest.uidaho.edu
> 
> 
> 
> 
>     
>         
>           
>   
> 
> 
> 
> 
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=39&dsMessageId=252537

To unsubscribe from this discussion, e-mail: [dev-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list