[GE users] adding Execution Host - Problems with Hostnames

reuti reuti at staff.uni-marburg.de
Mon Apr 12 10:13:50 BST 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Am 08.04.2010 um 05:11 schrieb neoideo:

> after trying many things,
> i found my problem was that i had to add on both /etc/hosts file the server hostnames, now i can properly add the execution host.
> 
> (somewhere in the process i had an issue because i was installing the execution host as "root",

Usually the daemons should run as root, to allow switching to other the real user during the execution of the job.


> then i changed to the normal user and it gave an error that it didnt had manager privileges 
> so in the master node i added the use raccount to manager list, is this a good solution?)
> 
> now, 
> the problem is that when i list the hosts with
> $ qhost
> the new added host appears with all his attributes as "-"

Then the qmaster judges the machine as unavailable. Is there any firewall running on the master blocking port 6444?

-- Reuti

> and when i ran this simple job.
> $ qrsh hostname
> i never got response.
> 
> any ideas where should i look ?
> 
> Cristobal
> 
> 
> 
> 
> On Wed, Apr 7, 2010 at 6:55 PM, Cristobal Navarro <axischire at gmail.com> wrote:
> Hello,
> 
> here is the escenario:
> 
> 2 mac pros.
> 
> one as master node, qmaster script installed correctly.
> his hostname is "mac-pro-3.local"
> 
> when i try to configure the execution host daemon, it fails trying to resolve "mac-pro-3".
> i think there is a problem with the hostname of the master node, i have tried changing it to "mac-pro-3" but no success.
> 
> the host is mounting the NFS shared folder.
> this is the error when trying installing execd on host
> 
> ---
> Cannot contact qmaster. The command failed:
> 
> ./bin/darwin-x86/qconf -sh
> 
> The error message was:
> 
> ERROR: unable to send message to qmaster using port 6444 on host ?mac-pro-3?: can?t resolve host name
> 
> You can fix the problem now or abort the installation procedure.
> The problem can be:
> 
> ? the qmaster is not running
> ? the qmaster host is down
> ? an active firewall blocks your request
> 
> Contact qmaster again (y/n) (?n? will abort) [y] >>
> 
> ---
> 
> i wish i could get rid of that "local" sufix permanently, i've tried modifiyng /etc/hosts  ,  scutil,  with no success.
> 
> both macs are Leopard 10.5.6
> 
> any help, advice is welcome, thanks in advance
> 
> 
> Cristobal
> 
> 
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=253107

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list