[GE users] Problems deploying reporting application

jana jana.olivova at sun.com
Wed Feb 3 13:15:38 GMT 2010


See inline

On 02/03/10 10:50, alopezga wrote:

On Tue 02 Feb 2010 (15:03), jana wrote:


Hi,



Hi there,



Yes, you have to create the directory as well.  The version string of
the directory com.sun.grid.arco_6.2u3 must be exactly the same as found
in the $SGE_ROOT/$SGE_CELL/reporting/util/app-3.0.xml. It is the version
specified in the managementApp element. I believe in one of the releases
there have been an error with the version string, i.e.  in the
app-xxx.xml files is a wrong version string.



I do not have that $SGE_ROOT/$SGE_CELL/reporting/ directory but
$SGE_ROOT/$SGE_CELL/arco/reporting/ (I don't know if this is correct).
However, I've checked the contents of the file you pointed nut in my
path (i.e. $SGE_ROOT/$SGE_CELL/arco/reporting/util/app-3.0.xml) and the
version is 6.2u4 (which is the version in my com.sun.grid.arco_?????
directory).



Sorry for the confusion. The path that I used, is a path where I unpack the binaries of reporting. During the installation the files get copied and other files necessary for the web console deployment get created in

$SGE_ROOT/$SGE_CELL/arco/reporting/  (this is the deployment directory)



So, this is all correct. I guess the only other advise I can give is to try to reinstall reporting again and restart the smcwebserver.

Regards,

Jana Olivova

Next, did the following directory exist?

/etc/opt/webconsole/console/



Yes it exists:

% ls /etc/opt/webconsole/console/
config.properties  default.properties  prereg/  regcache/
service.properties  status.properties

% cat /etc/opt/webconsole/console/service.properties
arco_app_dir=/opt/gridengine6.2/default/arco/reporting
arco_logging_level=INFO
arco_config_file=/opt/gridengine6.2/default/arco/reporting/config.xml



What exactly is the content of your reporting.reg file ?



% cat /etc/opt/webconsole/console/prereg/com.sun.grid.arco_6.2u4/reporting.reg
system=false
debug=0
context=reporting
type=webapp
location=/opt/gridengine6.2/default/arco/reporting

Regards,
A.

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=242865

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net<mailto:users-unsubscribe at gridengine.sunsource.net>].





More information about the gridengine-users mailing list