[GE users] Screencast/blog post on SGE 6.2u5 install on OS X

jlforrest jlforrest at berkeley.edu
Mon Feb 8 05:22:10 GMT 2010


On 2/7/2010 4:18 PM, craffi wrote:

> The core issue from what I have observed on multiple systems is that in
> modern versions of OS X the SGE binaries simply do not function when
> started as root via a shell script (like during SGE installation or a
> system startup script) or even when manually started by the root user
> acting at the command line. This breaks both installation and general
> startup on OS X.

Amen to that. This is the biggest problem
I've had running SGE on my pseudo-cluster.
This is what causes the "can't find password file
entry" error that you'll see if you ignore this
sage advice.

> Running SGE under launchd is not a big deal except for the fact that SGE
> wont' install cleanly now on OS X systems because the installer script
> launches sge_qmaster directly and this does not seem stable/reliable any
> more on updated 10.5 and 10.6.* based systems.

For some reason, I haven't had this problem with sge_qmaster - at least
not when I start it as root from a command prompt. In fact, due
to yet another mysterious bug (the fearsome ""Unable to initialize 
environment because of error: range_list containes no elements"
bug) I have to do this about once a week.

> You basically have to interrupt the installation process and continue
> manually after all the basic stuff like spooling and the SGE_CELL
> directory is sorted out.

Thanks so much, Chris, for taking the time to do this.
I boggles my pea brain that Sun hasn't done anything
about this since, as you point out, it means that
what they distribute for Mac OSX just plain doesn't run,
at least not without your excellent fixes.

I guess I can't expect perfection for free, but if I
were a paying customer I'd be highly bothered by this.

Cordially,
-- 
Jon Forrest
Research Computing Support
College of Chemistry
173 Tan Hall
University of California Berkeley
Berkeley, CA
94720-1460
510-643-1032
jlforrest at berkeley.edu

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=243901

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list