[GE issues] [Issue 3239] -terse option in sge_request files is ignored

rayson rayrayson at gmail.com
Sat Feb 13 01:52:52 GMT 2010


http://gridengine.sunsource.net/issues/show_bug.cgi?id=3239



User rayson changed the following:

                What    |Old value                 |New value
================================================================================
             Assigned to|pollinger                 |rayson
--------------------------------------------------------------------------------




------- Additional comments from rayson at sunsource.net Fri Feb 12 17:52:51 -0800 2010 -------
The problem is in clients/qsub/qsub.c :

Currently, the check is done on the command line options only:

   /*
    * Check if -terse is requested
    */
   if (opt_list_has_X(opts_cmdline, "-terse")) {
      has_terse = true;
   }

A similar check should be done on opts_defaults, which holds options from the default files. Or, if needed, do the check after the merge of 
all the options:

   /*
    * Merge all commandline options and interprete them
    */
   opt_list_merge_command_lines(&opts_all, &opts_defaults,
                                &opts_scriptfile, &opts_cmdline);

   if (opt_list_has_X(opts_all, "-terse")) {      /* possible fix for 3239 */
      has_terse = true;
   }

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=36&dsMessageId=244496

To unsubscribe from this discussion, e-mail: [issues-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list