[GE users] Sgemaster won't start after upgrading

heywood heywood at cshl.edu
Mon Feb 22 21:42:10 GMT 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

AFAIK, there are only lx24 binaries, not lx26 (that's all I have seen when
on Sun's site). Anyways, I downloaded ge62u5_lx24-amd64.tar.gz, and last
summer it was also lx24 (ge62u3_lx24-amd64.tar.gz).

Todd


On 2/22/10 4:32 PM, "m0zes" <adam.tygart at gmail.com> wrote:

> Just a wild guess, but, to me, it sounds like you downloaded the
> lx24-* courtesy binaries this time, when you were previously using the
> lx26-* binaries.
> 
> I would check to make sure I downloaded the correct ones, and if not
> get the new ones and install them.
> 
> --
> Adam
> 
> On Mon, Feb 22, 2010 at 15:18, heywood <heywood at cshl.edu> wrote:
>> No, it isn't hard coded. It returns lx26, while the directories are named
>> lx24...
>> 
>> [root at bhmnode2 ~]# $SGE_ROOT/util/arch
>> lx26-amd64
>> [root at bhmnode2 ~]# uname -a
>> Linux bhmnode2.cshl.edu 2.6.9-42.0.3.ELsmp #1 SMP Mon Sep 25 17:24:31 EDT
>> 2006 x86_64 x86_64 x86_64 GNU/Linux
>> [root at bhmnode2 ~]# ls -l $SGE_ROOT/bin
>> total 96
>> drwxr-xr-x  2 root root 4096 Feb 22 10:55 lx24-amd64
>> lrwxrwxrwx  1 root root   10 Feb 22 11:06 lx26-amd64 -> lx24-amd64
>> [root at bhmnode2 ~]#
>> 
>> (I defined that symlink to get things running this morning)
>> 
>> 
>> On 2/22/10 4:03 PM, "reuti" <reuti at staff.uni-marburg.de> wrote:
>> 
>>> Am 22.02.2010 um 18:54 schrieb heywood:
>>> 
>>>> No, we have not compiled SGE, but have used courtesy binaries all
>>>> along.
>>>> 
>>>> The /etc/init.d/{sgemaster,sgeexecd} scripts (which are from
>>>> installing
>>>> 6.2u3 last summer) are looking for lx26-*. But the utilbin and bin
>>>> directory
>>>> names are lx24-*.
>>> 
>>> You mean it's hardcoded in the script? AFAIK it always used the arch
>>> script in $SGE_ROOT/util/arch by default to determine the platform
>>> its running on. This should also return lx24-amd64 on your system.
>>> 
>>> -- Reuti
>>> 
>>> 
>>>> Todd
>>>> 
>>>> 
>>>> On 2/22/10 12:41 PM, "reuti" <reuti at staff.uni-marburg.de> wrote:
>>>> 
>>>>> Hi,
>>>>> 
>>>>> Am 22.02.2010 um 17:28 schrieb heywood:
>>>>> 
>>>>>> Well. For some reason the directory in $SGE_ROOT/utilbin and
>>>>>> $SGE_ROOT/bin
>>>>>> was "lx24-amd64", and the script was looking for "lx26-amd64". We
>>>>>> are
>>>>>> running kernel 2.6 and always have so I don't know where that lx24*
>>>>>> directory name came from.
>>>>> 
>>>>> the lx24-* is the minimum supported kernel by the provided binaries
>>>>> and will also work fine under kernel 2.6. But when you build SGE on
>>>>> your own on a 2.6 system, the created directories will be named
>>>>> according to the version it found, i.e. you get lx26-*. Did you
>>>>> compile it on your own?
>>>>> 
>>>>> -- Reuti
>>>>> 
>>>>> 
>>>>>> 
>>>>>> Anyways I just created a symlink lx26-amd64 -> lx24-amd64, and SGE
>>>>>> started
>>>>>> up.
>>>>>> 
>>>>>> Really weird.
>>>>>> 
>>>>>> Todd
>>>>>> 
>>>>>> 
>>>>>> On 2/22/10 10:32 AM, "heywood" <heywood at cshl.edu> wrote:
>>>>>> 
>>>>>>> No I did not.
>>>>>>> 
>>>>>>> I followed the patch instructions. I renamed the sge_shepherd
>>>>>>> with ?mv" and
>>>>>>> unpacked these tar.gz files:
>>>>>>> 
>>>>>>>  ge-6.2u5-bin-lx24-amd64.tar.gz
>>>>>>>  ge-6.2u5-common.tar.gz
>>>>>>>  hedeby-1.0u5-core.tar.gz
>>>>>>> 
>>>>>>> Then I tried restarting qmaster
>>>>>>> 
>>>>>>> Todd
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> On 2/22/10 10:25 AM, "craffi" <dag at sonsorol.org> wrote:
>>>>>>> 
>>>>>>>> The "can't find path" error is significant. Did you (or the init
>>>>>>>> script)
>>>>>>>> source or run the settings.sh|csh files to set up the SGE
>>>>>>>> environment
>>>>>>>> before trying to restart the qmaster?
>>>>>>>> 
>>>>>>>> -Chris
>>>>>>>> 
>>>>>>>> 
>>>>>>>> heywood wrote:
>>>>>>>>> I upgraded from 6.2u3 to 6.2u5, and now sgemaster will not start:
>>>>>>>>> 
>>>>>>>>> [root at bhmnode2 sge]# /etc/init.d/sgemaster.bh
>>>>>>>>> can't determine path to Grid Engine utility binaries
>>>>>>>>> [root at bhmnode2 sge]#
>>>>>>>> 
>>>>>>>> ------------------------------------------------------
>>>>>>>> 
>>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?
>>>>>> dsForumId=38&dsMessageId=24>>
>>>>>> 5
>>>>>>>> 435
>>>>>>>> 
>>>>>>>> To unsubscribe from this discussion, e-mail:
>>>>>>>> [users-unsubscribe at gridengine.sunsource.net].
>>>>>>> 
>>>>>>> ------------------------------------------------------
>>>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?
>>>>>>> dsForumId=38&dsMessageId=245
>>>>>>> 436
>>>>>>> 
>>>>>>> To unsubscribe from this discussion, e-mail:
>>>>>>> [users-unsubscribe at gridengine.sunsource.net].
>>>>>> 
>>>>>> ------------------------------------------------------
>>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?
>>>>>> dsForumId=38&dsMessageId=245442
>>>>>> 
>>>>>> To unsubscribe from this discussion, e-mail: [users-
>>>>>> unsubscribe at gridengine.sunsource.net].
>>>>> 
>>>>> ------------------------------------------------------
>>>>> http://gridengine.sunsource.net/ds/viewMessage.do?
>>>>> dsForumId=38&dsMessageId=245
>>>>> 454
>>>>> 
>>>>> To unsubscribe from this discussion, e-mail:
>>>>> [users-unsubscribe at gridengine.sunsource.net].
>>>> 
>>>> ------------------------------------------------------
>>>> http://gridengine.sunsource.net/ds/viewMessage.do?
>>>> dsForumId=38&dsMessageId=245455
>>>> 
>>>> To unsubscribe from this discussion, e-mail: [users-
>>>> unsubscribe at gridengine.sunsource.net].
>>> 
>>> ------------------------------------------------------
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=2
>>> 45
>>> 473
>>> 
>>> To unsubscribe from this discussion, e-mail:
>>> [users-unsubscribe at gridengine.sunsource.net].
>> 
>> ------------------------------------------------------
>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=24
>> 5476
>> 
>> To unsubscribe from this discussion, e-mail:
>> [users-unsubscribe at gridengine.sunsource.net].
>> 
> 
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=245
> 480
> 
> To unsubscribe from this discussion, e-mail:
> [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=245483

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list