[GE users] ARCO install "Must have administration privileges"

hugo hugo.hernandez at nih.gov
Fri Feb 26 18:39:59 GMT 2010


Hello there,
I have same problems and after running changes for RHEL I was able to load Grid Engine 6.2u4 ARCo on the Java Web Console but now, when I click on the link I have this exception message:

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Can't open config file '/usr/sge/niaid/arco/reporting/config.xml ', check the property arco_config_file
	com.sun.grid.arco.web.ArcoServletBase.initConfigFile(ArcoServletBase.java:139)
	com.sun.grid.arco.web.ArcoServletBase.init(ArcoServletBase.java:102)
	com.sun.grid.arco.web.arcomodule.ArcoServlet.init(ArcoServlet.java:60)
	sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	java.lang.reflect.Method.invoke(Method.java:597)
	org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:243)
	java.security.AccessController.doPrivileged(Native Method)
	javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
	org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:272)
	org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:161)
	org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:114)
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
	org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
	org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
	org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
	org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
	java.lang.Thread.run(Thread.java:619)


Somebody have any idea how to work around it?  We are using SGE 6.2u4, RHEL 5.4 and jdk1.6.0_18.

Also, I am not sure if the web application is correctly deployed for the Java console and when I try to add one I got the message "Must have administration privileges to execute this command and I am running the command as root!  How can I add users in able to deploy web applications into the Java web console?

Any help will be really appreciated!

Thanks,
-Hugo

# wcadmin list

Must have administration privileges to list deployed web applications.

Registered jar files (application name, identifier, path):

    console  console_jars  /opt/sun/webconsole/lib/*.jar
    console  jato_jar      /opt/sun/share/lib/jato.jar
    console  javahelp_jar  /usr/java/packages/javax.help-2.0/javahelp/lib/*.jar
    console  shared_jars   /opt/sun/webconsole/private/container/shared/lib/*.jar

Registered login modules (application name, service name, identifier):

    console  ConsoleLogin  userlogin

Shared service properties (name, value):

    ENABLE            yes
    arco_app_dir      /usr/sge/niaid/arco/reporting
    java.home         /niaid/java
    arco_logging_level  INFO
    arco_config_file  /usr/sge/niaid/arco/reporting/config.xml

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=246218

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list