[GE users] "NOT" expression in qsub command ?

templedf dan.templeton at sun.com
Thu Jan 14 18:13:49 GMT 2010


You want:

  qsub -q clusterqueuename -l h='!hostgroupname' .....

Daniel

cjf001 wrote:
> Guys -
>
> I'm trying to understand the "expressions" part of the sge_types
> man page, and whether it's even applicable to what I'd like to
> do....
>
>
> I can currently request a queue as follows:
>
>     qsub -q clusterqueuename@@hostgroupname .....
>
> and I can put wildcards in there too, as in:
>
>     qsub -q *@@hostgroupname .....    (gets any cluster queue on hostgroupname)
>     qsub -q clusterqueuename@@* ..... (gets clusterqueuename on any hostgroup)
>
>
> but what I'd like to do is is request to NOT get a particular
> hostgroup or clusterqueue. It would seem that something like this:
>
>     qsub -q ! clusterqueuename@@hostgroupname
>
> might work, but it doesn't, and neither can I get any combination of
> quotes, parens, etc to work - either I get a shell error or qsub error.
>
> Anybody ever done this, and/or know the right syntax to make something
> like this work ?
>
>      TIA !
>
>        John
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=238786
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=238804

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list