[GE users] ARCO install "Must have administration privileges"

bdbaddog bill at baddogconsulting.com
Mon Jan 18 23:42:07 GMT 2010


Allan,

Yes I followed the manual, and also the troubleshooting page here:
http://wikis.sun.com/display/gridengine62u3/ARCo+Troubleshooting

-Bill

On Mon, Jan 18, 2010 at 3:39 PM, Bill Deegan <bill at baddogconsulting.com> wrote:
> Allan,
>
> Was that on RHEL4?
>
> -Bill
>
> On Mon, Jan 18, 2010 at 3:32 PM, allantran <tran.v.allan at gmail.com> wrote:
>> I have arco installed quite sometime ago. Did you follow the guide from sun?
>> That's what I did.
>> Here is my config, hope it helps.
>> root at admin:~[1001]>cat /etc/opt/webconsole/console/service.properties
>> #Console shared services properties
>> #Fri Dec 19 17:14:40 EST 2008
>> ENABLE=yes
>> arco_app_dir=/usr/local/sge/6.2/default/arco/reporting
>> java.home=/usr/java/jdk1.5.0_04
>> arco_logging_level=INFO
>> arco_config_file=/usr/local/sge/6.2/default/arco/reporting/config.xml
>>
>> root at admin:~[1002]>cat
>> /etc/opt/webconsole/console/prereg/com.sun.grid.arco_6.2/reporting.reg
>> ## webapp registration notification
>> #Fri Dec 19 17:14:39 EST 2008
>> system=false
>> debug=0
>> context=reporting
>> type=webapp
>> location=/usr/local/sge/6.2/default/arco/reporting
>> I'm running webconsole 3.0.2 also.
>> On Thu, Jan 14, 2010 at 2:24 PM, mhanby <mhanby at uab.edu> wrote:
>>>
>>> I actually found this same info on the mailing list archives.
>>>
>>> Some comments / problems:
>>>
>>> 1. "Manually edit the /etc/opt/webconsole/console/service.properties file
>>> and add the following properties (replace the paths with fully qualified
>>> names):"
>>>
>>> This file does not exist on my system, I had to create it. Are the three
>>> lines the only lines needed in the file, or are there others needed for core
>>> web console functionality?
>>>
>>> 2. "Create file reporting.reg in
>>> /etc/opt/webconsole/console/prereg/com.sun.grid.arco_6.2u3"
>>>
>>> The "com.sun.grid.arco_6.2u3" directory also did not exist. I had to
>>> create it but I used my GE version "com.sun.grid.arco_6.2u4" in case it
>>> matters
>>>
>>> Are there any other files expected under com.sun.grid.arco_6.2u4?
>>>
>>> 3. Regarding the "No application is registered..." issue, I confirmed that
>>> registrationservlet.jar and the tld directory are present.
>>>
>>> $JAVA_HOME points to /usr/java/latest which links to /usr/java/jdk1.6.0_16
>>>
>>> This is set for all users and was present during execution of
>>> inst_reporting
>>>
>>> Should I be using a newer version of Web Console? I installed 3.0.2
>>>
>>> -----Original Message-----
>>> From: mhanby [mailto:mhanby at uab.edu]
>>> Sent: Thursday, January 14, 2010 3:08 PM
>>> To: users at gridengine.sunsource.net
>>> Subject: RE: [GE users] ARCO install "Must have administration privileges"
>>>
>>> Thanks Dan, surprisingly enough, google didn't bring that page up :-)
>>>
>>> I'd forgotten about that page.
>>>
>>> Here's the link for the other RedHat'rs
>>> http://wikis.sun.com/display/GridEngine/ARCo+Troubleshooting
>>>
>>> Mike
>>>
>>> -----Original Message-----
>>> From: Dan.Templeton at sun.com [mailto:Dan.Templeton at sun.com]
>>> Sent: Thursday, January 14, 2010 12:40 PM
>>> To: users at gridengine.sunsource.net
>>> Subject: Re: [GE users] ARCO install "Must have administration privileges"
>>>
>>> You're using RedHat, aren't you? :)  Check the troubleshooting section
>>> of the ARCo docs.  That problem (and the solution) is explained there.
>>>
>>> Daniel
>>>
>>> mhanby wrote:
>>> > Howdy,
>>> >
>>> > I'm attempting to install ARCO for GE6.2u4 running RHEL5.4 x86_64
>>> >
>>> > I have dbwriter running properly and updating the database.
>>> >
>>> > During the inst_reporting portion, the only errors displayed are these:
>>> >
>>> > Registering the GE reporting module in the Sun Java Web Console
>>> > ---------------------------------------------------------------
>>> > Must have administration privileges to execute this command.
>>> > Must have administration privileges to execute this command.
>>> > Must have administration privileges to execute this command.
>>> > Must have administration privileges to execute this command.
>>> > Creating the TOC file ... OK
>>> >
>>> > After which, Sun Java Web Console is restarted. After logging into the
>>> > console (https://<ip>:6789) it reports:
>>> >
>>> > No application is registered with this Sun Java(TM) Web Console, or you
>>> > have no rights to use any applications that are registered.
>>> >
>>> > I suspect that the web console parts aren't getting installed. Any idea
>>> > what I need to do to get this installed properly?
>>> >
>>> > I'm running the script as root, so the "Must have administration" error
>>> > must be talking about the web console authentication and not the local file
>>> > system permissions.
>>> >
>>> > Thanks for any ideas.
>>> >
>>> > Mike
>>> >
>>> > =================================
>>> > Mike Hanby
>>> > mhanby at uab.edu
>>> > Information Systems Specialist II
>>> > IT HPCS / Research Computing
>>> >
>>> > ------------------------------------------------------
>>> >
>>> > http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=238802
>>> >
>>> > To unsubscribe from this discussion, e-mail:
>>> > [users-unsubscribe at gridengine.sunsource.net].
>>> >
>>>
>>> ------------------------------------------------------
>>>
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=238811
>>>
>>> To unsubscribe from this discussion, e-mail:
>>> [users-unsubscribe at gridengine.sunsource.net].
>>>
>>> ------------------------------------------------------
>>>
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=238839
>>>
>>> To unsubscribe from this discussion, e-mail:
>>> [users-unsubscribe at gridengine.sunsource.net].
>>>
>>> ------------------------------------------------------
>>>
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=238845
>>>
>>> To unsubscribe from this discussion, e-mail:
>>> [users-unsubscribe at gridengine.sunsource.net].
>>
>>
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=239630

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list