[GE users] SGE and OpenMPI 1.3.2

olesen Mark.Olesen at emconTechnologies.com
Thu Jan 21 14:48:25 GMT 2010


> This is what I'm using for my openmpi PE for a reference:
>
> $ qconf -sp openmpi
> pe_name            openmpi
> slots              9999
> user_lists         NONE
> xuser_lists        NONE
> start_proc_args    /bin/true
> stop_proc_args     /bin/true
> allocation_rule    $fill_up
> control_slaves     TRUE
> job_is_first_task  FALSE
> urgency_slots      min
> accounting_summary FALSE


Is '/bin/true' correct? I have

  start_proc_args    NONE
  stop_proc_args     NONE


> I haven't quite decided whether or not to use
> "accounting_summary TRUE" yet, as it doesn't seem to account
> properly for parallel jobs.

I don't bother with accounting there either. Instead I parse the
accounting file and count the slots/walltime.
For our system the overall time that machines and licenses are occupied
is the primary accounting factor.

/mark

This e-mail message and any attachments may contain legally privileged, confidential or proprietary Information, or information otherwise protected by law of EMCON Technologies, its affiliates, or third parties. This notice serves as marking of its "Confidential" status as defined in any confidentiality agreements concerning the sender and recipient. If you are not the intended recipient(s), or the employee or agent responsible for delivery of this message to the intended recipient(s), you are hereby notified that any dissemination, distribution or copying of this e-mail message is strictly prohibited. 
If you have received this message in error, please immediately notify the sender and delete this e-mail message from your computer.

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=240185

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list