[GE users] Qsub strange behaviours

spow_ miomax_ at hotmail.com
Tue Jul 27 11:07:39 BST 2010

    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi everyone,

I have been running simple and parallel jobs altogether to see what would happen, and did observe behaviours I wasn't expecting at all. It might well come from the version I am currently using (6 N1) but I can't test on 6.2u5 until HP installed it on our cluster.

- Our users will sometimes have to chose their queue (to prevent having their jobs preempted), so I tried to submit a few just to verify it works with:

qsub job.sh -q queue(.q)

Which doesn't send the job where it is supposed to. It picks a queue randomly.
While reading the manpages, I found the -hard option, but it doesn't work either.

- Also, I use subordinates. The problem is that only part of the queue get suspended ! (e.g. my queue sub1 runs across 2 hosts, and only the sub1 at host1 gets suspended, whereas it is very clear the whole queue should be suspended).

- Eventually, I ran parallel jobs, with $round_robin allocation. If I submit a limited number of jobs, they get correctly dispatched.
But if a few jobs are already running in the parallel queues, SGE dispatches the next job on both the queues. This behaviour is really bad for our cluster, as one parallel job really shouldn't span across multiple queues.

Are these 'bugs' (for all I know it might be on purpose) ?
Is the behaviour the same in 6.2u5 ?

Thanks for having read,

Votre vie privée l'est-elle vraiment ? Internet Explorer 8 vous prot?ge gratuitement<http://clk.atdmt.com/FRM/go/232102478/direct/01/>

More information about the gridengine-users mailing list