[GE users] Issue seen in 6.2U5 : memory values reported by SGE too low compared to top output on linux systems

shruti_m shruti at synopsys.com
Wed Mar 10 18:10:45 GMT 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hi Reuti/Stephen,



Actual data is being written to memory. Both VIRT and RES values are quite high compared to vmem reported by SGE. It is easily reproducible and consistent in behavior.



=======================================================================================================



top - 10:08:48 up 104 days, 13:52, 11 users,  load average: 1.00, 0.69, 0.30

Tasks: 124 total,   2 running, 122 sleeping,   0 stopped,   0 zombie

Cpu(s): 24.4% us,  0.7% sy,  0.0% ni, 74.8% id,  0.1% wa,  0.0% hi,  0.1% si

Mem:  16409180k total, 12688836k used,  3720344k free,    69944k buffers

Swap: 33557960k total,   127132k used, 33430828k free,   427984k cached



  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND

14517 shruti    25   0 11.7g  11g  23m R 99.9 73.2   5:13.35 common_shell_ex


=======================================================================================================

usage    1:                 cpu=00:04:44, mem=512.92204 GBs, io=0.00000, vmem=2.681G, maxvmem=3.997G

=======================================================================================================



Thanks,

Shruti





-----Original Message-----
From: stephendennis [mailto:sdennis at univaud.com]
Sent: Wednesday, March 10, 2010 6:21 AM
To: users at gridengine.sunsource.net
Subject: RE: [GE users] Issue seen in 6.2U5 : memory values reported by SGE too low compared to top output on linux systems



Hello Shruti



When you allocated the memory did you also write data into it?

Until you do the allocation is virtual.



Stephen

________________________________________

From: shruti_m [shruti at synopsys.com]

Sent: Tuesday, March 09, 2010 6:37 PM

To: users at gridengine.sunsource.net

Subject: [GE users] Issue seen in 6.2U5 : memory values reported by SGE too low compared to top output on linux systems



Hi All,



We recently upgraded one of the sites to 6.2U5. Since the upgrade, we have noticed that vmem and maxvmem values reported by qstat in SGE is much low compared to real time mem consumed by the job and reflected in top output of the system.



e.g I submit a job to grab 20G memory and hold it for 300 sec. In top output, I do see my job consuming upto 20G memory for 300 sec?qstat output shows maxvmem to have never exceeded 3G !! It is easibly reproducible on lx24-amd64 systems.



Let me know, if anybody else has seen similar behavior.



Thanks,

Shruti



------------------------------------------------------

http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=247841



To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list