[GE users] qmaster SEGVs

fx d.love at liverpool.ac.uk
Mon Mar 15 10:23:09 GMT 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

ckoe <christof.koehler at bccms.uni-bremen.de> writes:

> The most annoying thing is that it breaks part of the spooling database
> every time, e.g. users are simply _gone_. Excerpt from qmaster messages:

Fortunately I haven't seen that :-/.

> Attaching gdb to a running qmaster shows that the crashes happen in
> different subroutines (the courtesy binaries do not contain complete
> debug info ?), for example cull_hash_free_descr or lCopySwitchPack.

Sodd's law says the crashes will stop before I get a chance to run gdb,
but I can run with debugging info, so assuming it carries on happening,
I should be able to get at least stack traces and/or a brief gdb
session.

> The OS is ubuntu 9.10 amd64, courtesy binaries, classic spooling on
> NFSv3, schedd_job_info false, using a lot of wildcard stuff for PE's.

I don't use those binaries in the absence of an appropriate licence, but
we have the same spooling, schedd_job_info true, and also make use of PE
wildcards.  The crashes don't correspond to any SGE configuration
change, though.

-- 
(Dr) Dave Love
?E-Science?, Computing Services Department, University of Liverpool
AKA fx at gnu.org

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=248693

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list