[GE users] Problems with load_sensor and complex

alopezga aloga at ifca.unican.es
Tue Mar 16 08:56:15 GMT 2010


Dear list,

I'm having some problems with load_sensors, complexes and consumables.

I've defined a 'load_sensor' for my scratch space with
'qconf -mconf global'. This load sensor reports a complex like that:

begin
wn001:scratch_space:90G
end

Which is the correct scratch space. Then, I've added it to the complex
as follows:

   scratch_space  scratch  MEMORY  <=  YES  YES  0  0

If I check with qhost, the information seems coherent:

 $ qhost -F scratch_space -h wn001
 (...)
     Host Resource(s):      hl:scratch_space=90.000G

But If I submit a job and request that resource with 

  qsub -l scratch_space=2G

I'm always getting the following message in the schedd info of the job:

  cannot run in queue (...) because job requests unknown resource (scratch_space)

Should I define it somewhere else in order to make it work?

Then I've tried to add it to the host global configuration, by adding it
to the complex_values of the 'qconf -me global'. For example, I've added
a scratch_space=100G to that list. But if I run the 'qhost' command I'm
getting negative values!

  $ qhost -F scratch_space -h wn001
  global                  -               -     -       -       -       -       -
      Host Resource(s):      gc:scratch_space=-1112.000G
  (...)
      Host Resource(s):      hl:scratch_space=-1112.000G

If I turn off the complex from being consumable the negative values
dissapear, but I want my scratch space to be a consumable resource. From
complex man page I read:

"In the case of a consumable on host level, which has also a load sensor,
 the system checks for the current usage, and if the internal accounting
 is more restrictive than the load sensor report, the internal value is
 kept; if the load sensor report is more restrictive, that one is kept."

Did I miss something? Any hints/clues?

Regards,
Alvaro.

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=248906

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list