[GE users] [Solved] Cluster Partitioning via PEs

aeszter Ansgar.Esztermann at mpi-bpc.mpg.de
Tue Mar 16 14:32:15 GMT 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

On Mar 15, 2010, at 13:54 , aeszter wrote:
> 
> I was under the impression that I could use host groups for nodes connected to a common switch, then define somthing like implicit parallel environments in the queue config like this:
> 
> pe_list intelmpi,[@ib1=intelmpi_ib1],[@ib2=intelmpi_ib2]

Some further research proved me wrong: the above config line does not instantiate the intelmpi_* PEs from a template PE (intelmpi). Rather, it assigns different PEs to different instances of the queue: something.q@@ib1 has intelmpi_ib1, something.q@@ib2 has intelmpi_ib2, and every other instance has intelmpi.
So, I have defined intelmpi_ib1 and intelmpi_ib2 to be identical copies of intelmpi (except for the names, of course). After creating these, qconf added a queue with the above pe_list all right.




A.
-- 
Ansgar Esztermann
DV-Systemadministration
Max-Planck-Institut für biophysikalische Chemie, Abteilung 105

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=248969

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list