[GE users] Does "qdel" command not recognized in Korn-Shell ?

arvindpetaru arvindpetaru at gmail.com
Tue May 4 22:23:31 BST 2010


No.....PATH is same for both shells.

> Looks like a difference in your PATH between the two shells, is that 
> possible?
> 
> Dan
> 
> On 05/04/2010 04:48 PM, arvindpetaru wrote:
> > Hi,
> >
> >    I was trying a simple script to execute but it fails to recognize "qdel" command in the script/job if I selected shell as "ksh" (i.e., #$ -S /bin/ksh), but it works fine when the shell is "sh"(bourne shell). Am i missing something here. FYI, I sourced the settings.sh file. I'd appreciate if anyone can give me some inputs here. Below is my simple script.
> >
> > File:test.sh
> > ------------------------------------------
> > #!/bin/ksh
> >
> > #$ -S /bin/ksh
> > #Works fine if above is /bin/sh
> >
> > #$ -M ramki at gmail.com
> > #$ -m abes
> > #$ -cwd
> > #$ -V
> > #$ -o /tmp/nohup.out
> > #$ -j y
> > #$ -l hostname=lperf011
> >
> > echo "SCRIPT STARTED"
> > sleep 5
> > qdel $JOB_ID
> > sleep 5
> > echo "SCRIPT ENDED"
> > exit 0
> >
> > ---------------------------------
> >
> > Script o/p:
> > -------------
> > SCRIPT STARTED
> > /tmp/sge/ge6.2/default/spool//lperf011/job_scripts/15[15]: qdel:  not found
> > SCRIPT ENDED
> >
> > ------------------------------------------------------
> > http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256157
> >
> > To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
> >

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256171

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list