[GE users] Moved to users list: Re: [GE issues] Calendar and advance reservation

reuti reuti at staff.uni-marburg.de
Thu May 6 18:39:22 BST 2010


Am 06.05.2010 um 14:24 schrieb fredwag:

> On 05/06/2010 12:14 PM, Reuti wrote:
>> Hi,
>> 
>> (the issues list is mainly for the emails which are send automatically when changes to the issues database are made)
>> 
>> Am 06.05.2010 um 09:06 schrieb fredwag:
>> 
>>> Hi .*,
>>> 
>>> I have a problem in SGE 6.2u1:
>>> 
>>> We have setup for visulization system with multiple nodes and multiple
>>> graphics cards per node. Through SGE a users can reserve a graphics card
>>> to do their visualization job, for this an advance reservation system is
>>> configured (its a batch queue, but interactive work).
>>> 
>>> Now there is the demand for a nightly batch queue (no ar) for normal
>>> dataprocessing jobs (since the machines have lots of memory and they
>>> idle during the night). So I configured a 'nightly' batch queue, with a
>>> calendar attached to it (4-20=off 20-4=on).
>>> 
>>> My problem now is the following:
>>> As soon there exists an advance reservation (for an already running job
>>> or for the future) _no_ jobs are running in nightly queue. The scheduler
>>> info gives (when the queue is by calendar enabled):
>>> '(-l NONE) cannot run in queue "nightly at somehost..." because it offers
>>> only qc:slots=0.000000 due to a reservation'

And the AR will end before the nighly queue is active? Maybe the slots are enabled by the calendar then, but allocated to the AR.

Can you give more details about the setup?

-- Reuti


>>> 
>>> What could be the problem here?
>>> 
>>> The jobs in nightly _are_ running, when
>>> * I take away the calendar, so the job is always enabled
>>> * no advance reservation exists
>>> 
>>> I already played with the scheduler parameters Maximum
>>> Reservation/Default Duration etc...
>>> 
>>> It seems that the complex slots is somehow influenced by pending
>>> reservations... but why? Is this a 'backfilling' problem? I don't know
>>> where to search anymore. Or is this a bug?
>> 
>> there one issue which I also observed with RQS:
>> 
>> http://gridengine.sunsource.net/issues/show_bug.cgi?id=2761
>> 
>> Are you using RQS?
> 
> no, we are not using RQS, just an advance reservation queue and a normal
> queue with calender.
> 
> Thanks and bye,
> Frederik
> 
>> 
>> -- Reuti
>> 
>> 
>> 
>>> Thanks a lot for any help!
>>> Bye,
>>> Frederik
>>> 
>>> ------------------------------------------------------
>>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=36&dsMessageId=256351
>>> 
>>> To unsubscribe from this discussion, e-mail: [issues-unsubscribe at gridengine.sunsource.net].
>> 
> 
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256386
> 
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256422

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list