[GE users] qsh xterm

reuti reuti at staff.uni-marburg.de
Fri May 7 22:47:32 BST 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Am 07.05.2010 um 23:32 schrieb brianandrus:

> When I use 'qrsh xterm' I get
>
> xterm Xt error: Can't open display: localhost:10.0
>
>
> I have X forwarding setup. From the submit node, I can 'xterm' and  
> get the window back.
> From the submit node, I can 'ssh compute-1-10' and then run 'xterm'  
> and get the window back.
>
> The pertinent settings in qconf -mconf:
>
> xterm                        /usr/bin/xterm

The above entry is only used for the plain `qsh` for wich it would be  
necessary to allow a direct connection from the slave node to the  
user's workstation. Also the access must be granted by a `xhost +`.  
This all is considered unsafe nowaday. Background: http://gridengine.sunsource.net/ds/viewMessage.do?dsMessageId=65347&dsForumId=38


> qlogin_command               builtin
> qlogin_daemon                builtin
> rlogin_command               builtin
> rlogin_daemon                builtin
> rsh_command                  builtin
> rsh_daemon                   builtin
>
>
> I am a bit of a newbie, so I am not sure what 'builtin' translates  
> to. I suspect I may need to change one or more of these to 'ssh -Y'?

Yep, here:

http://gridengine.sunsource.net/howto/qrsh_qlogin_ssh.html

you may also want to include the -Y / -X there (it could even be put  
in the global /etc/ssh/ssh_config or each user's ~/ssh/config as  
ForwardX11 yes / ForwardX11Trusted Yes) .

If you want to avoid passphraseless ssh-keys, you can also setup  
hostbased authentication:

http://gridengine.sunsource.net/howto/hostbased-ssh.html

-- Reuti

PS: The -builtin- might supply X11 forwarding at a later point.


>
> Brian Andrus
>
> -----Original Message-----
> From: reuti [mailto:reuti at staff.uni-marburg.de]
> Sent: Friday, May 07, 2010 1:22 PM
> To: users at gridengine.sunsource.net
> Subject: Re: [GE users] qsh xterm
>
> Hi,
>
> Am 07.05.2010 um 19:43 schrieb brianandrus:
>
>> I am trying to get qsh to run and provide an xterm window on our
>> cluster.
>>
>> When I run ?qsh xterm?, it immediately returns:
>
> can you please try:
>
> $ qrsh xterm
>
> It's necessary to setup SSH as communication in SGE's configuration
> with enabled X11 forwarding.
>
> -- Reuti
>
>
>>
>> error: Unknown option script
>>
>> If I just run qsh alone, it successfully schedules a job, which is
>> there and then goes away.
>> I tried googling around to see what the above error is, but cannot
>> find anything.
>>
>> Any help will be appreciated.
>>
>> Brian Andrus
>>
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256568
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net 
> ].
>
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256575
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net 
> ].
>

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=256578

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list