[GE users] question about queues and limitations to specific nodes

jnorris jnorris at ucmerced.edu
Wed May 12 22:52:46 BST 2010


Thanks to all for your comments and help - attached are the two queues

gragghia wrote:
> To only allow certain users use of the IB machines, I would make them a 
> cluster queue and then only set the "allow" list.  Explicitly added the 
> "deny" list is not needed.
>
> How is the file /opt/mpdd_tmp/hydra.hosts being created?  If it is 
> dynamic, you should cat the contents of this file out to ensure that it 
> contains the correct hosts.  You may also want to execute "qstat -g t" 
> within the batch script to show what SGE thinks it is allocating to you.
>
> If you provide the output for "qconf -sq ib.q" and "qconf -sq 
> ethernet.q" it will help a lot in determining the source of the problem.
>
> - Gerald
>
>
> On 5/12/2010 4:28 PM, jnorris wrote:
>   
>> Hello to all,
>>
>> Here is the situation:
>>
>> I have 66 nodes total in my cluster - I need to allow select users to
>> access the first 8 nodes and all users access the remaining nodes.
>>
>> The first 8 nodes I put into a queue ib.q and the rest in ethernet.q  I
>> set the exclude user list on IB to all of the user lists of those that
>> should not be allowed and the user list to the users that are allowed.
>> With ethernet.q  I have all user list in users and NONE for exclude users.
>>
>> Then I did some testing with a simple hello script that keeps track of
>> what node its running on and prints the message:
>>
>> Hello from process 0 on c1
>> Hello from process 1 on c2
>> Hello from process 2 on c3
>> Hello from process 3 on c4
>> Hello from process 4 on c5
>> Hello from process 5 on c6
>> Hello from process 6 on c7
>> Hello from process 7 on c8
>>
>>
>> I set the #$ -q ethernet.q  in the script and set the run as:
>>
>> mpiexec.hydra  -f /opt/mpdd_tmp/hydra.hosts  -n 10 ./hello
>>
>> The out put above is what I obtain.  Ok here are my questions:
>>
>> 1)  is this the best way to do this? - I am real newbie to sge
>> 2)  by the scenario above and considering that c1-c8 are the nodes that
>> should not be in this output - what am I doing wrong?
>>
>> Thank beforehand for any and all help.
>>
>>
>>
>>    
>>     
>
>   

-- 
Joseph Norris
Application Developer & Server Administrator
209-228-4576
jnorris at ucmerced.edu

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=257118

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

    [ Part 2, "ethernet_q"  Text/PLAIN (Name: "ethernet_q") ~2.5 KB. ]
    [ Unable to print this part. ]


    [ Part 3, "ib_q"  Text/PLAIN (Name: "ib_q") ~2.5 KB. ]
    [ Unable to print this part. ]



More information about the gridengine-users mailing list