[GE users] Lockfiles and not doing the process on the same file.

reuti reuti at staff.uni-marburg.de
Mon May 17 10:36:24 BST 2010


Hi,

Am 15.05.2010 um 21:13 schrieb mnuzaihan:

> I am having a problem. We do encoding of large and many videos over the gridengine cluster. However, the problem is no matter how much i tried to create a lockfile in the script so the other machines would know there's a lockfile (if the encoding is started on one machine) and try to encode the next file. It doesn't seem to work. 

how do you create the lockfile - and where?

But: there is nothing inside SGE which would prevent a race-condition, where two nodes would start with the same with the same movie. The lockfile-creation will never be atomic when you do it inside the script.

Can't you just give the filename to the script, and each submitted job will handle exactly this movie? So there wouldn't be a need for a lockfile.

-- Reuti


> Is there someone who had done this before? Any workarounds to this problem?
> 
> Thanks in advance!
> 
> Muhammad Nuzaihan
> 
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=257423
> 
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=257578

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list