[GE users] Using h_vmem to prevent out of control memory usage

murple andreas.kuntzagk at mdc-berlin.de
Thu May 27 10:12:26 BST 2010


Hi,

I run into the same just using -Xmx this week.

Andreas

griznog wrote:
> On Mon, Mar 29, 2010 at 2:01 PM, mhanby <mhanby at uab.edu> wrote:
>> Howdy (GE 6.2u5 on CentOS 5 x86_64),
>>
>> I'm testing using h_vmem as a way to prevent jobs from getting out of control with their memory usage.
>>
>> I ran my test job without using h_vmem and the job completed successfully reporting
>> "Max vmem         = 1.920G".
>>
>> I repeated the same job, but this time adding "-l h_vmem=2G" and it fails very quick:
>> + java -jar test.jar
>>
>> Error occurred during initialization of VM
>> Could not reserve enough space for object heap
>> Could not create the Java virtual machine.
>>
>> I also tried "-l h_vmem=3G" and "-l h_vmem=3G,h_stack=32M" and they also fail very quick with the similar error.
>>
>> If I specify "-l h_vmem=10G,h_stack=32M" then the job runs successfully.
>>
> 
> Mike,
> 
> We ran into this issue as well, our jobs look like:
> 
> java -Xms2g -Xmx2g -XX:MaxPermSize=2g -cp . HelloWorld
> 
> What we found through trial and error is that h_vmem has to be set to
> at least twice whatever these parameters are. I'm not a java person so
> I don't know which of these is the actual culprit and just setting
> h_vmem high enough has fixed our problem so we probably won't dig into
> it much more. If anyone knows exactly what is going on I'd be curious
> to hear an explanation.
> 
> jbh
> 
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=258080
> 
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=258941

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list