[GE users] MPI woes

reuti reuti at staff.uni-marburg.de
Mon Nov 8 09:36:06 GMT 2010


Am 05.11.2010 um 07:12 schrieb heine:

> I have changed loglevel, but do not notice any more info than before.

the messages created as info will have an "I" instead of an "W", "E" or "C" in the column next to the message.

>> > administrator_mail           
>> heine at sun.ac.za
>> > set_token_cmd                none
>> > pag_cmd                      none
>> > token_extend_time            none
>> > shepherd_cmd                 none
>> > qmaster_params               none
>> > execd_params                 none
>> > reporting_params             accounting=true reporting=true \
>> >                             flush_time=00:00:15 joblog=true sharelog=00:00:00
>> > finished_jobs                100
>> > gid_range                    20000-21000
>> > max_aj_instances             2000
>> > max_aj_tasks                 75000
>> > max_u_jobs                   0
>> > max_jobs                     0
>> > max_advance_reservations     0
>> > qlogin_command               /usr/local/bin/qlogin_wrapper
>> > qlogin_daemon                /usr/sbin/sshd -i
>> what about the entries:
>> rlogin_command               builtin
>> rlogin_daemon                builtin
>> rsh_command                  builtin
>> rsh_daemon                   builtin
> I have tried this before, but I guess there must be a secret to set it. All I get get when trying to set it to builtin is 'denied: the path given for "rsh_daemon" must start with a "/"'

Then I would assume, that you are still running an older version. As you write below, that you upgraded, did you upgrade all daemons on all machines and restaretd them? For older version the suitable settings are:


But for 6.2u5 "builtin" should work for sure. Are you accessing the correct binaries for the recent version?

>> They seem missing. Unless you need X11 forwarding, I would suggest to stay with "builtin" for `qlogin` too.
>> Are there local configurations defined for some nodes (`qconf -sconfl`)? In a cluster where all machines have the same OS this can be removed, as it was introduced to allow different paths to some applications on the various OS in a heterogenous cluster.
> All I have is 'xterm                        /usr/bin/xterm'

In principle this is fine, but I would suggest to remove all local configurations as you don't need them. `qconf -dconf node001` or alike.

> Thank you for your help thus far. I appreciate it. I have only recently taken over administration of our cluster and upgraded from 6.0u12 to 6.2u5, but I do not think the problem is related to the upgrade. I think it has actually never worked before as I noticed some postings in out local mailing list about problems before.

How did you upgrade?

-- Reuti


To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

More information about the gridengine-users mailing list