[GE users] Can't request a boolean complex

prentice prentice at ias.edu
Wed Oct 6 22:05:08 BST 2010


Disregard the plea for help below. Sure enough, I was being stupid. I
had set cuda=false at the queue level to test something the other day,
and forgot about it. My bad. Sorry.

Prentice


prentice wrote:
> Okay, group, I know I must be doing something stupid here.
> 
> I added a couple of hosts with tesla cards, and I defined an attribute
> on those hosts called "CUDA" and set it's value to true. On the other
> hosts, cuda is set to false.
> 
> I then defined a complex "cuda", as shown below
> 
> $ qconf -sc | egrep ^"#|cuda"
> #name               shortcut   type        relop   requestable
> consumable default  urgency
> #------------------------------------------------------------------------------------------
> cuda                cuda       BOOL        ==      YES         NO
>   FALSE    0
> 
> Now when I request an interactive shell on one these machines by
> specifying -l cuda=true, I get an error:
> 
> $ qrsh -l cuda=true
> Your "qrsh" request could not be scheduled, try again later.
> 
> $ qrsh -l cuda==true
> attribute "cuda" is not a boolean value
> 
> But if I specify cuda=false, this works:
> 
> $ qrsh -l cuda=false
> Last login: Wed Jul  7 16:55:23 2010 from juno.XXX.XXX.XXX
> [prentice at jupiter ~]$
> 
> Any idea what I'm overlooking? Did I define cuda incorrectly on my hosts?
> 
> 

-- 
Prentice Bisbal
Linux Software Support Specialist/System Administrator
School of Natural Sciences
Institute for Advanced Study
Princeton, NJ

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=286273

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list